summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMirco Bauer <meebey@meebey.net>2009-07-29 20:29:33 +0200
committerMirco Bauer <meebey@meebey.net>2009-07-29 20:29:33 +0200
commitb9af3bcea75b9518b9147583ca7760d673e95e0f (patch)
tree832dcc632f0e095e2f59f9d166c90326e89278e7 /configure.in
parent9b2da0eb623df784864c8c5de5ad08051fb7e9f3 (diff)
downloadmono-b9af3bcea75b9518b9147583ca7760d673e95e0f.tar.gz
Imported Upstream version 2.4.2.3+dfsgupstream/2.4.2.3+dfsg
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in74
1 files changed, 58 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 39dd4cf38c..32b3763c38 100644
--- a/configure.in
+++ b/configure.in
@@ -6,7 +6,7 @@ AC_CANONICAL_SYSTEM
m4_ifdef([_A][M_PROG_TAR],[_A][M_SET_OPTION([tar-ustar])])
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(mono,2.4)
+AM_INIT_AUTOMAKE(mono,2.4.2.3)
AM_MAINTAINER_MODE
API_VER=1.0
@@ -64,6 +64,14 @@ need_link_unlink=no
AC_MSG_CHECKING([host platform characteristics])
libgc_threads=no
has_dtrace=no
+
+case "$host" in
+ powerpc*-*-linux*)
+ # https://bugzilla.novell.com/show_bug.cgi?id=504411
+ disable_munmap=yes
+ ;;
+esac
+
case "$host" in
*-*-mingw*|*-*-cygwin*)
platform_win32=yes
@@ -139,7 +147,10 @@ case "$host" in
;;
*-*-linux*)
platform_win32=no
- CPPFLAGS="$CPPFLAGS -DGC_LINUX_THREADS -D_GNU_SOURCE -D_REENTRANT -DUSE_MMAP -DUSE_MUNMAP"
+ CPPFLAGS="$CPPFLAGS -DGC_LINUX_THREADS -D_GNU_SOURCE -D_REENTRANT -DUSE_MMAP"
+ if test "x$disable_munmap" != "xyes"; then
+ CPPFLAGS="$CPPFLAGS -DUSE_MUNMAP"
+ fi
libmono_cflags="-D_REENTRANT"
libmono_ldflags="-lpthread"
libdl="-ldl"
@@ -360,13 +371,19 @@ fi
# A sanity check to catch cases where the package was unpacked
# with an ancient tar program (Solaris)
#
-AC_MSG_CHECKING(integrity of package)
-if test -f $srcdir/$mcsdir/class/System.Runtime.Serialization.Formatters.Soap/System.Runtime.Serialization.Formatters.Soap/SoapTypeMapper.cs
-then
- AC_MSG_RESULT(ok)
-else
- errorm="Your mono distribution is incomplete; if unpacking from a tar file, make sure you use GNU tar; see http://www.mono-project.com/IncompletePackage for more details"
- AC_MSG_ERROR([$errorm])
+AC_ARG_ENABLE(solaris-tar-check,
+[ --disable-solaris-tar-check disable solaris tar check],
+ do_solaris_tar_check=no, do_solaris_tar_check=yes)
+
+if test x"$do_solaris_tar_check" = xyes; then
+ AC_MSG_CHECKING(integrity of package)
+ if test -f $srcdir/$mcsdir/class/System.Runtime.Serialization.Formatters.Soap/System.Runtime.Serialization.Formatters.Soap/SoapTypeMapper.cs
+ then
+ AC_MSG_RESULT(ok)
+ else
+ errorm="Your mono distribution is incomplete; if unpacking from a tar file, make sure you use GNU tar; see http://www.mono-project.com/IncompletePackage for more details"
+ AC_MSG_ERROR([$errorm])
+ fi
fi
mcs_topdir='$(top_srcdir)/'$mcsdir
@@ -462,13 +479,18 @@ system)
## Versions of dependencies
GLIB_REQUIRED_VERSION=1.3.11
-
- PKG_CHECK_MODULES(BASE_DEPENDENCIES, glib-2.0 >= $GLIB_REQUIRED_VERSION)
-
- GLIB_CFLAGS=`$PKG_CONFIG --cflags glib-2.0 gthread-2.0`
- GLIB_LIBS=`$PKG_CONFIG --libs glib-2.0 gthread-2.0`
- GMODULE_CFLAGS=`$PKG_CONFIG --cflags gmodule-2.0`
- GMODULE_LIBS=`$PKG_CONFIG --libs gmodule-2.0`
+
+ dnl
+ dnl No, you will not replace this check with a pkg.m4 check
+ dnl
+ if $PKG_CONFIG --atleast-version=$GLIB_REQUIRED_VERSION glib-2.0; then
+ GLIB_CFLAGS=`$PKG_CONFIG --cflags glib-2.0 gthread-2.0`
+ GLIB_LIBS=`$PKG_CONFIG --libs glib-2.0 gthread-2.0`
+ GMODULE_CFLAGS=`$PKG_CONFIG --cflags gmodule-2.0`
+ GMODULE_LIBS=`$PKG_CONFIG --libs gmodule-2.0`
+ else
+ AC_MSG_ERROR([You need at least glib-2.0 $GLIB_REQUIRED_VERSION])
+ fi
;;
*)
AC_MSG_ERROR([Invalid argument to --with-glib.])
@@ -1946,6 +1968,19 @@ case "$host" in
;;
esac
+# FIXME: Define the others as well
+case "$TARGET" in
+X86)
+ AC_DEFINE(TARGET_X86, 1, [...])
+ ;;
+AMD64)
+ AC_DEFINE(TARGET_AMD64, 1, [...])
+ ;;
+ARM)
+ AC_DEFINE(TARGET_ARM, 1, [...])
+ ;;
+esac
+
if test "x$sizeof_register" = "x4"; then
AC_DEFINE(SIZEOF_REGISTER,4,[size of machine integer registers])
elif test "x$sizeof_register" = "x8"; then
@@ -2395,6 +2430,13 @@ if test x$platform_win32 = xyes; then
sed -e "s,-mno-cygwin,,g" libtool > libtool.new; mv libtool.new libtool; chmod 755 libtool
fi
+dnl
+dnl Consistency settings
+dnl
+if test x$cross_compiling = xyes -o x$enable_mcs_build = xno; then
+ DISABLE_MCS_DOCS=yes
+fi
+
(
case $prefix in
NONE) prefix=$ac_default_prefix ;;