summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJo Shields <directhex@apebox.org>2014-02-19 22:56:41 +0000
committerJo Shields <directhex@apebox.org>2014-02-19 22:56:41 +0000
commitf9f077cbdc52123a3828bbb475bd7111c8d6c150 (patch)
tree66c059d911f465e3b275f8955a475a922403fd80 /configure.in
parentb369b84d1bdb59abb34e3ac93c24f7f252d4c84b (diff)
parentb5c7654dd78182fdb806f0558b71aa37c8d05cd4 (diff)
downloadmono-f9f077cbdc52123a3828bbb475bd7111c8d6c150.tar.gz
Merge branch 'master-experimental-patches/kfreebsd_support' into merge/3.2.8+dfsg
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 493f671c2a..a043c1ebcf 100644
--- a/configure.in
+++ b/configure.in
@@ -143,6 +143,17 @@ case "$host" in
with_sigaltstack=no
use_sigposix=yes
;;
+ *-*-kfreebsd*-gnu)
+ platform_win32=no
+ CPPFLAGS="$CPPFLAGS -DGC_FREEBSD_THREADS -D_GNU_SOURCE -D_REENTRANT -DUSE_MMAP -DUSE_MUNMAP -DTHREAD_LOCAL_ALLOC -pthread"
+ libmono_cflags="-D_REENTRANT -DTHREAD_LOCAL_ALLOC -pthread"
+ libmono_ldflags="-lpthread -pthread"
+ libdl="-ldl"
+ libgc_threads=pthreads
+ need_link_unlink=yes
+ with_sigaltstack=no
+ use_sigposix=yes
+ ;;
*-*-*freebsd*)
host_win32=no
if test "x$PTHREAD_CFLAGS" = "x"; then
@@ -2551,7 +2562,7 @@ case "$host" in
sgen_supported=true
AOT_SUPPORTED="yes"
;;
- darwin*|openbsd*|freebsd*)
+ darwin*|openbsd*|freebsd*|kfreebsd-gnu*)
sgen_supported=true
;;
esac
@@ -2569,7 +2580,7 @@ case "$host" in
sgen_supported=true
AOT_SUPPORTED="yes"
;;
- darwin*|openbsd*|freebsd*)
+ darwin*|openbsd*|freebsd*|kfreebsd-gnu*)
sgen_supported=true
;;
esac
@@ -2925,6 +2936,11 @@ case "$host" in
LIBC="libc.so.12"
INTL="libintl.so.0"
;;
+ *-*-kfreebsd*-gnu)
+ LIBC="libc.so.0.1"
+ INTL="libc.so.0.1"
+ X11="libX11.so.6"
+ ;;
*-*-*freebsd*)
LIBC="libc.so"
INTL="libintl.so"