summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJo Shields <directhex@apebox.org>2014-02-20 08:35:37 +0000
committerJo Shields <directhex@apebox.org>2014-02-20 09:29:59 +0000
commit0b1a48e6c3489a2de7e0bd77eaf0fb71d943b5b0 (patch)
tree30f107bc5356eb1192309682a1faae91db225b68 /debian
parente2acadbd2565cdcff9b4730fe39e52593bbfa227 (diff)
downloadmono-0b1a48e6c3489a2de7e0bd77eaf0fb71d943b5b0.tar.gz
Delete some corner-case build rules for working around arch issues
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules15
1 files changed, 1 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 6f9673976a..060c2c55d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,18 +61,6 @@ else
MONO_BOEHM_TEST = cd mono/tests && MONO_ENV_OPTIONS=--gc=boehm $(TIMEOUT) make test; $(KILL_MONO)
MONO_SGEN_TEST = cd mono/tests && MONO_ENV_OPTIONS=--gc=sgen $(TIMEOUT) make test; $(KILL_MONO)
endif
-ifeq ($(DEB_BUILD_ARCH), powerpc)
- MONO_SGEN_TEST = true
-endif
-
-MDB_REL = mono-debugger
-ifeq ($(DISTRO), Ubuntu)
- MDB_VARS = -Vmdb:Suggests=$(MDB_REL)
- MDB_VARS += -Vmdb:Recommends=
-else
- MDB_VARS = -Vmdb:Suggests=
- MDB_VARS += -Vmdb:Recommends=$(MDB_REL)
-endif
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
@@ -356,8 +344,7 @@ binary-indep: build-stamp install-stamp
# mono-1.0/2.0-gac needs special runtime dep, to prevent circular dep (mono-runtime <-> mono-1.0/2.0-gac)
debian/dh_clideps -p mono-2.0-gac -r $(DH_INTERNAL_MONO_PARAM)
debian/dh_clideps -p mono-4.0-gac -r $(DH_INTERNAL_MONO_PARAM)
- dh_gencontrol -i -- -Vmono:upversion=$(UPVERSION) -Vmono:next-upversion=$(NEXT_UPVERSION) \
- $(MDB_VARS)
+ dh_gencontrol -i -- -Vmono:upversion=$(UPVERSION) -Vmono:next-upversion=$(NEXT_UPVERSION)
dh_md5sums -i
dh_builddeb -i