summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJo Shields <directhex@apebox.org>2014-02-20 07:13:34 +0000
committerJo Shields <directhex@apebox.org>2014-02-20 09:29:59 +0000
commite2acadbd2565cdcff9b4730fe39e52593bbfa227 (patch)
tree275f598e1bc8d7c7173cad83eb7de3dbb2144d55 /debian
parent029af3f5c1ebb26969ca1f8843ddea407ce71076 (diff)
downloadmono-e2acadbd2565cdcff9b4730fe39e52593bbfa227.tar.gz
Don't use killall to kill stray Mono processes, it doesn't work as desired. (Closes: #738277)
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 77c67f0b6f..2dc584d7b3 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian Mono Group <pkg-mono-group@lists.alioth.debian.org>
Uploaders: Mirco Bauer <meebey@debian.org>, Jo Shields <directhex@apebox.org>
Build-Depends: debhelper (>= 7),
dpkg-dev (>= 1.16.1~),
- psmisc,
+ procps,
bison,
libtool,
libxml-dom-perl,
diff --git a/debian/rules b/debian/rules
index f5622f8c87..6f9673976a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,7 @@ NEXT_UPVERSION = $(shell perl -e '$$_=pop; s/(\d+)$$/$$1+1/e; print' $(UPVERSION
DEB_SOURCE_NAME = $(shell dpkg-parsechangelog -l$(DEBIAN_DIR)/changelog | grep ^Source | cut -d" " -f2)
RUN_MONO = LD_LIBRARY_PATH=debian/tmp/usr/lib MONO_PATH=debian/tmp/usr/lib/mono/4.0 debian/tmp/usr/bin/mono
+KILL_MONO = pgrep mono | xargs kill -9
DH_INTERNAL_MONO_PARAM = --internal-mono
ifeq ($(shell dpkg --compare-versions $$(dpkg-query -f '$${Version}' -W debhelper) lt 7.1; echo $$?), 0)
DH_INTERNAL_MONO_PARAM = internal-mono
@@ -56,7 +57,6 @@ ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
MONO_SGEN_TEST = true
else
TIMEOUT = timeout -k 1h 1h
- KILL_MONO = killall -9 mono
MINI_TEST = cd mono/mini && $(TIMEOUT) make check; $(KILL_MONO)
MONO_BOEHM_TEST = cd mono/tests && MONO_ENV_OPTIONS=--gc=boehm $(TIMEOUT) make test; $(KILL_MONO)
MONO_SGEN_TEST = cd mono/tests && MONO_ENV_OPTIONS=--gc=sgen $(TIMEOUT) make test; $(KILL_MONO)
@@ -130,6 +130,7 @@ test-stamp: build-stamp
-$(MINI_TEST)
-$(MONO_BOEHM_TEST)
-$(MONO_SGEN_TEST)
+ -$(KILL_MONO)
# funny bug-459094.cs creates too long directory names which
# pbuilder is unable to remove, eh
rm -rf mono/tests/abcde12345abcde12345abcde12345abcde12345/