summaryrefslogtreecommitdiff
path: root/eglib
diff options
context:
space:
mode:
authorJo Shields <directhex@apebox.org>2011-02-16 22:45:03 +0000
committerJo Shields <directhex@apebox.org>2011-02-16 22:45:03 +0000
commit24a880a3d798d10c6f40c91fcf8343e030e4c43d (patch)
tree899f6655fb0e493dc70dcdf3894aa2f0ccb361ee /eglib
parent98cb87c3c08e317dbff60033741b7b6749f1bdcf (diff)
downloadmono-24a880a3d798d10c6f40c91fcf8343e030e4c43d.tar.gz
Imported Upstream version 2.10upstream/2.10
Diffstat (limited to 'eglib')
-rw-r--r--eglib/ChangeLog19
-rwxr-xr-xeglib/configure3
-rw-r--r--eglib/configure.ac2
-rw-r--r--eglib/src/Makefile.am1
-rw-r--r--eglib/src/Makefile.in37
-rw-r--r--eglib/src/eglib-config.h45
-rw-r--r--eglib/src/glib.h4
-rw-r--r--eglib/src/vasprintf.c2
8 files changed, 45 insertions, 68 deletions
diff --git a/eglib/ChangeLog b/eglib/ChangeLog
index f66a9e2ca5..f31ea41be4 100644
--- a/eglib/ChangeLog
+++ b/eglib/ChangeLog
@@ -1,3 +1,22 @@
+2011-02-07 Hib Eris <hib@hiberis.nl>
+
+ Do not distribute eglib-config.h
+
+ The file eglib-config.h is generated when running configure.
+ Distributing eglib-config.h in tarballs causes errors when
+ building out of the source tree.
+
+2011-02-07 Hib Eris <hib@hiberis.nl>
+
+ Use _vscprintf() for mingw-w64 compilers
+
+ The mingw-w64 compilers implement a vsnprintf() function that do
+ not conform to the C99 standard (just like MSVC).
+
+2011-02-07 Zoltan Varga <vargaz@gmail.com>
+
+ Include sys/types.h for pid_t on mingw. Fixes #670076.
+
2011-01-11 Christian Hergert <chris@dronelabs.com>
Fix broken g_int_hash/g_int_equal semantics
diff --git a/eglib/configure b/eglib/configure
index b16b2de571..5e43570a40 100755
--- a/eglib/configure
+++ b/eglib/configure
@@ -13306,7 +13306,8 @@ fi
-for ac_header in getopt.h sys/time.h sys/wait.h pwd.h langinfo.h iconv.h localcharset.h
+
+for ac_header in getopt.h sys/time.h sys/wait.h pwd.h langinfo.h iconv.h localcharset.h sys/types.h
do
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
diff --git a/eglib/configure.ac b/eglib/configure.ac
index 7d52c708ef..659a4f61aa 100644
--- a/eglib/configure.ac
+++ b/eglib/configure.ac
@@ -126,7 +126,7 @@ if test "x$have_iso_varargs" = "xyes"; then
fi
AC_SUBST(G_HAVE_ISO_VARARGS)
-AC_CHECK_HEADERS(getopt.h sys/time.h sys/wait.h pwd.h langinfo.h iconv.h localcharset.h)
+AC_CHECK_HEADERS(getopt.h sys/time.h sys/wait.h pwd.h langinfo.h iconv.h localcharset.h sys/types.h)
AC_CHECK_HEADER(alloca.h, [HAVE_ALLOCA_H=1], [HAVE_ALLOCA_H=0])
AC_SUBST(HAVE_ALLOCA_H)
diff --git a/eglib/src/Makefile.am b/eglib/src/Makefile.am
index 189d6988fe..6ef2c53ac6 100644
--- a/eglib/src/Makefile.am
+++ b/eglib/src/Makefile.am
@@ -24,7 +24,6 @@ os_files = $(unix_files)
endif
libeglib_la_SOURCES = \
- eglib-config.h \
eglib-remap.h \
sort.frag.h \
glib.h \
diff --git a/eglib/src/Makefile.in b/eglib/src/Makefile.in
index 8d283e6f33..c8e869631a 100644
--- a/eglib/src/Makefile.in
+++ b/eglib/src/Makefile.in
@@ -48,15 +48,15 @@ LTLIBRARIES = $(noinst_LTLIBRARIES)
am__DEPENDENCIES_1 =
@HOST_WIN32_TRUE@am__DEPENDENCIES_2 = $(am__DEPENDENCIES_1)
libeglib_static_la_DEPENDENCIES = $(am__DEPENDENCIES_2)
-am__libeglib_static_la_SOURCES_DIST = eglib-config.h eglib-remap.h \
- sort.frag.h glib.h garray.c gbytearray.c gerror.c ghashtable.c \
- gmem.c gmodule.h goutput.c gstr.c gslist.c gstring.c \
- gptrarray.c glist.c gqueue.c gpath.c gshell.c gspawn.c gfile.c \
- gfile-posix.c gpattern.c gmarkup.c gutf8.c gunicode.c \
- unicode-data.h gdate-unix.c gdir-unix.c gfile-unix.c \
- gmisc-unix.c gmodule-unix.c gtimer-unix.c eglib-config.hw \
- gdate-win32.c gdir-win32.c gfile-win32.c gmisc-win32.c \
- gmodule-win32.c gtimer-win32.c vasprintf.c
+am__libeglib_static_la_SOURCES_DIST = eglib-remap.h sort.frag.h glib.h \
+ garray.c gbytearray.c gerror.c ghashtable.c gmem.c gmodule.h \
+ goutput.c gstr.c gslist.c gstring.c gptrarray.c glist.c \
+ gqueue.c gpath.c gshell.c gspawn.c gfile.c gfile-posix.c \
+ gpattern.c gmarkup.c gutf8.c gunicode.c unicode-data.h \
+ gdate-unix.c gdir-unix.c gfile-unix.c gmisc-unix.c \
+ gmodule-unix.c gtimer-unix.c eglib-config.hw gdate-win32.c \
+ gdir-win32.c gfile-win32.c gmisc-win32.c gmodule-win32.c \
+ gtimer-win32.c vasprintf.c
am__objects_1 = libeglib_static_la-gdate-unix.lo \
libeglib_static_la-gdir-unix.lo \
libeglib_static_la-gfile-unix.lo \
@@ -91,15 +91,15 @@ libeglib_static_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
$(libeglib_static_la_CFLAGS) $(CFLAGS) \
$(libeglib_static_la_LDFLAGS) $(LDFLAGS) -o $@
@HOST_WIN32_TRUE@libeglib_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
-am__libeglib_la_SOURCES_DIST = eglib-config.h eglib-remap.h \
- sort.frag.h glib.h garray.c gbytearray.c gerror.c ghashtable.c \
- gmem.c gmodule.h goutput.c gstr.c gslist.c gstring.c \
- gptrarray.c glist.c gqueue.c gpath.c gshell.c gspawn.c gfile.c \
- gfile-posix.c gpattern.c gmarkup.c gutf8.c gunicode.c \
- unicode-data.h gdate-unix.c gdir-unix.c gfile-unix.c \
- gmisc-unix.c gmodule-unix.c gtimer-unix.c eglib-config.hw \
- gdate-win32.c gdir-win32.c gfile-win32.c gmisc-win32.c \
- gmodule-win32.c gtimer-win32.c vasprintf.c
+am__libeglib_la_SOURCES_DIST = eglib-remap.h sort.frag.h glib.h \
+ garray.c gbytearray.c gerror.c ghashtable.c gmem.c gmodule.h \
+ goutput.c gstr.c gslist.c gstring.c gptrarray.c glist.c \
+ gqueue.c gpath.c gshell.c gspawn.c gfile.c gfile-posix.c \
+ gpattern.c gmarkup.c gutf8.c gunicode.c unicode-data.h \
+ gdate-unix.c gdir-unix.c gfile-unix.c gmisc-unix.c \
+ gmodule-unix.c gtimer-unix.c eglib-config.hw gdate-win32.c \
+ gdir-win32.c gfile-win32.c gmisc-win32.c gmodule-win32.c \
+ gtimer-win32.c vasprintf.c
am__objects_6 = libeglib_la-gdate-unix.lo libeglib_la-gdir-unix.lo \
libeglib_la-gfile-unix.lo libeglib_la-gmisc-unix.lo \
libeglib_la-gmodule-unix.lo libeglib_la-gtimer-unix.lo
@@ -296,7 +296,6 @@ unix_files = \
@HOST_WIN32_FALSE@os_files = $(unix_files)
@HOST_WIN32_TRUE@os_files = $(win_files)
libeglib_la_SOURCES = \
- eglib-config.h \
eglib-remap.h \
sort.frag.h \
glib.h \
diff --git a/eglib/src/eglib-config.h b/eglib/src/eglib-config.h
deleted file mode 100644
index e3ff6ed43d..0000000000
--- a/eglib/src/eglib-config.h
+++ /dev/null
@@ -1,45 +0,0 @@
-#ifndef __EGLIB_CONFIG_H
-#define __EGLIB_CONFIG_H
-
-/*
- * System-dependent settings
- */
-#define G_GNUC_PRETTY_FUNCTION
-#define G_GNUC_UNUSED __attribute__((__unused__))
-#define G_BYTE_ORDER G_LITTLE_ENDIAN
-#define G_GNUC_NORETURN __attribute__((__noreturn__))
-#define G_SEARCHPATH_SEPARATOR_S ":"
-#define G_SEARCHPATH_SEPARATOR ':'
-#define G_DIR_SEPARATOR '/'
-#define G_DIR_SEPARATOR_S "/"
-#define G_BREAKPOINT() G_STMT_START { __asm__ ("int $03"); } G_STMT_END
-#define G_OS_UNIX
-#define GPOINTER_TO_INT(ptr) ((gint)(long) (ptr))
-#define GPOINTER_TO_UINT(ptr) ((guint)(long) (ptr))
-#define GINT_TO_POINTER(v) ((gpointer)(glong) (v))
-#define GUINT_TO_POINTER(v) ((gpointer)(gulong) (v))
-
-#if 1 == 1
-#define G_HAVE_ALLOCA_H
-#endif
-
-typedef unsigned long gsize;
-typedef signed long gssize;
-
-#define G_GSIZE_FORMAT "lu"
-#define G_GUINT64_FORMAT "lu"
-#define G_GINT64_FORMAT "ld"
-
-#if 1 == 1
-#define G_HAVE_ISO_VARARGS
-#endif
-
-#if defined (__native_client__)
-#define sem_trywait(x) sem_wait(x)
-#define sem_timedwait(x,y) sem_wait(x)
-#define getdtablesize() (32768)
-#undef G_BREAKPOINT
-#define G_BREAKPOINT()
-#endif
-
-#endif
diff --git a/eglib/src/glib.h b/eglib/src/glib.h
index 8b6082e83a..3485015468 100644
--- a/eglib/src/glib.h
+++ b/eglib/src/glib.h
@@ -16,6 +16,10 @@
/* For pid_t */
#ifndef WIN32
#include <unistd.h>
+#else
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
#endif
#endif
diff --git a/eglib/src/vasprintf.c b/eglib/src/vasprintf.c
index 8699df289b..56e1971c68 100644
--- a/eglib/src/vasprintf.c
+++ b/eglib/src/vasprintf.c
@@ -9,7 +9,7 @@ int vasprintf(char **ret, const char *fmt, va_list ap)
size_t buflen;
va_list ap2;
-#ifdef _MSC_VER
+#if defined(_MSC_VER) || defined(__MINGW64_VERSION_MAJOR)
ap2 = ap;
len = _vscprintf(fmt, ap2); // NOTE MS specific extension ( :-( )
#else