summaryrefslogtreecommitdiff
path: root/mono/metadata/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mono/metadata/Makefile.am')
-rw-r--r--mono/metadata/Makefile.am24
1 files changed, 14 insertions, 10 deletions
diff --git a/mono/metadata/Makefile.am b/mono/metadata/Makefile.am
index 0b47ca6093..f5040c5a89 100644
--- a/mono/metadata/Makefile.am
+++ b/mono/metadata/Makefile.am
@@ -337,13 +337,8 @@ endif
if !HOST_WIN32
if SUPPORT_BOEHM
-test_sgen_qsort_SOURCES = test-sgen-qsort.c
-test_sgen_qsort_CFLAGS = $(SGEN_DEFINES)
-test_sgen_qsort_LDADD = libmonoruntimesgen.la ../io-layer/libwapi.la ../utils/libmonoutils.la \
- $(LIBGC_LIBS) $(GLIB_LIBS) -lm $(LIBICONV)
-if PLATFORM_DARWIN
-test_sgen_qsort_LDFLAGS=-framework CoreFoundation
-endif
+noinst_PROGRAMS = test-gc-memfuncs
+TESTS = test-gc-memfuncs
test_gc_memfuncs_SOURCES = test-gc-memfuncs.c
test_gc_memfuncs_CFLAGS = $(SGEN_DEFINES)
@@ -353,9 +348,18 @@ if PLATFORM_DARWIN
test_gc_memfuncs_LDFLAGS=-framework CoreFoundation
endif
-noinst_PROGRAMS = test-sgen-qsort test-gc-memfuncs
-
-TESTS = test-sgen-qsort test-gc-memfuncs
+if SUPPORT_SGEN
+noinst_PROGRAMS += test-sgen-qsort
+TESTS += test-sgen-qsort
+test_sgen_qsort_SOURCES = test-sgen-qsort.c
+test_sgen_qsort_CFLAGS = $(SGEN_DEFINES)
+test_sgen_qsort_LDADD = libmonoruntimesgen.la ../io-layer/libwapi.la ../utils/libmonoutils.la \
+ $(LIBGC_LIBS) $(GLIB_LIBS) -lm $(LIBICONV)
+if PLATFORM_DARWIN
+test_sgen_qsort_LDFLAGS=-framework CoreFoundation
+endif
+endif SUPPORT_SGEN
endif SUPPORT_BOEHM
+
endif !HOST_WIN32