summaryrefslogtreecommitdiff
path: root/debian/Makefile
diff options
context:
space:
mode:
authorNathan Scott <nathans@sgi.com>2002-02-25 22:41:02 +0000
committerNathan Scott <nathans@sgi.com>2002-02-25 22:41:02 +0000
commitde366b9e522ee084a318aaca25c3dd916b5114db (patch)
tree1c5e6e9a58a4906abb733e413d7a9a11cfd1c8ee /debian/Makefile
parent27204a8361ff975ddf3a60b95cc24f4e5ec7bed8 (diff)
downloadattr-de366b9e522ee084a318aaca25c3dd916b5114db.tar.gz
Merge of xfs-cmds-2.4.18:slinx:112273a by nathans.
sync up with patch from AndreasG, mainly creates libattr.rpm/deb.
Diffstat (limited to 'debian/Makefile')
-rw-r--r--debian/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
index b3d3d7b..3337824 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -35,6 +35,7 @@ include $(TOPDIR)/include/builddefs
LSRCFILES = changelog control copyright rules
DEV_DOC_DIR = $(PKG_DOC_DIR)/../$(PKG_NAME)-dev
+LIB_DOC_DIR = $(PKG_DOC_DIR)/../lib$(PKG_NAME)1
default:
@@ -53,3 +54,11 @@ ifeq ($(PKG_DISTRIBUTION), debian)
$(INSTALL) -m 644 copyright $(DEV_DOC_DIR)
$(INSTALL) -m 644 changelog $(DEV_DOC_DIR)/changelog.Debian
endif
+
+install-lib: default
+ifeq ($(PKG_DISTRIBUTION), debian)
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+ $(INSTALL) -m 755 -d $(LIB_DOC_DIR)
+ $(INSTALL) -m 644 copyright $(LIB_DOC_DIR)
+ $(INSTALL) -m 644 changelog $(LIB_DOC_DIR)/changelog.Debian
+endif