summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorInternet Software Consortium, Inc <@isc.org>2007-11-15 21:13:31 -0700
committerLaMont Jones <lamont@debian.org>2007-11-15 21:13:31 -0700
commit14844197c23f37b19e272cb34cb6f0f862598d36 (patch)
treed12bb00afd217ab6cfcc1aa9d2754ef8a693f69b /configure.in
parent10df5197b0b46b9f8e34b3855e9373c00c63b5a9 (diff)
downloadbind9-14844197c23f37b19e272cb34cb6f0f862598d36.tar.gz
9.5.0a7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 26 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 069c48ef..354f4a00 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ AC_DIVERT_PUSH(1)dnl
esyscmd([sed "s/^/# /" COPYRIGHT])dnl
AC_DIVERT_POP()dnl
-AC_REVISION($Revision: 1.429 $)
+AC_REVISION($Revision: 1.432 $)
AC_INIT(lib/dns/name.c)
AC_PREREQ(2.59)
@@ -429,6 +429,21 @@ case "$use_openssl" in
*-hp-hpux*)
DNS_OPENSSL_LIBS="-L$use_openssl/lib -Wl,+b: -lcrypto"
;;
+ *-apple-darwin*)
+ #
+ # Apple's ld seaches for serially for dynamic
+ # then static libraries. This means you can't
+ # use -L to override dynamic system libraries
+ # with static ones when linking. Instead
+ # we specify a absolute path.
+ #
+ if test -f "$use_openssl/lib/libcrypto.dylib"
+ then
+ DNS_OPENSSL_LIBS="-L$use_openssl/lib -lcrypto"
+ else
+ DNS_OPENSSL_LIBS="$use_openssl/lib/libcrypto.a"
+ fi
+ ;;
*)
DNS_OPENSSL_LIBS="-L$use_openssl/lib -lcrypto"
;;
@@ -2044,6 +2059,13 @@ case "$hack_shutup_stdargcast" in
;;
esac
+AC_CHECK_HEADERS(strings.h,
+ ISC_PLATFORM_HAVESTRINGSH="#define ISC_PLATFORM_HAVESTRINGSH 1"
+,
+ ISC_PLATFORM_HAVESTRINGSH="#undef ISC_PLATFORM_HAVESTRINGSH"
+)
+AC_SUBST(ISC_PLATFORM_HAVESTRINGSH)
+
#
# Check for if_nametoindex() for IPv6 scoped addresses support
#
@@ -2685,6 +2707,9 @@ AC_CONFIG_FILES([
lib/isc/$thread_dir/Makefile
lib/isc/$thread_dir/include/Makefile
lib/isc/$thread_dir/include/isc/Makefile
+ lib/isc/$arch/Makefile
+ lib/isc/$arch/include/Makefile
+ lib/isc/$arch/include/isc/Makefile
lib/isccc/Makefile
lib/isccc/include/Makefile
lib/isccc/include/isccc/Makefile