summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2009-03-20 08:23:23 -0600
committerLaMont Jones <lamont@debian.org>2009-03-20 08:23:23 -0600
commit95cab7ab13c7aedf768b3273a9a736f23239c18f (patch)
tree8c3bda91eb3defc1c5ce1f40a58a6898a2c35cf7 /configure.in
parent08ba6b17bb4653d8401e266e9249620c9fe89404 (diff)
downloadbind9-95cab7ab13c7aedf768b3273a9a736f23239c18f.tar.gz
9.6.0b1
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 21 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4a913caa..70fe29a0 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ AC_DIVERT_PUSH(1)dnl
esyscmd([sed "s/^/# /" COPYRIGHT])dnl
AC_DIVERT_POP()dnl
-AC_REVISION($Revision: 1.452 $)
+AC_REVISION($Revision: 1.456 $)
AC_INIT(lib/dns/name.c)
AC_PREREQ(2.59)
@@ -244,6 +244,15 @@ case "$host" in
STD_CDEFINES="$STD_CDEFINES -D_XPG4_2 -D__EXTENSIONS__"
CPPFLAGS="$CPPFLAGS -D_XPG4_2 -D__EXTENSIONS__"
;;
+ # POSIX doesn't include the IPv6 Advanced Socket API and glibc hides
+ # parts of the IPv6 Advanced Socket API as a result. This is stupid
+ # as it breaks how the two halves (Basic and Advanced) of the IPv6
+ # Socket API were designed to be used but we have to live with it.
+ # Define _GNU_SOURCE to pull in the IPv6 Advanced Socket API.
+ *-linux*)
+ STD_CDEFINES="$STD_CDEFINES -D_GNU_SOURCE"
+ CPPFLAGS="$CPPFLAGS -D_GNU_SOURCE"
+ ;;
esac
AC_HEADER_STDC
@@ -1161,6 +1170,16 @@ case "$host" in
esac
#
+# Work around Solaris's select() limitations.
+#
+case "$host" in
+ *-solaris2.[[89]]|*-solaris2.1?)
+ AC_DEFINE(FD_SETSIZE, 65536,
+ [Solaris hack to get select_large_fdset.])
+ ;;
+esac
+
+#
# Purify support
#
AC_MSG_CHECKING(whether to use purify)
@@ -1205,7 +1224,7 @@ AC_SUBST(PURIFY)
#
# GNU libtool support
#
-case $host in
+case $build_os in
sunos*)
# Just set the maximum command line length for sunos as it otherwise
# takes a exceptionally long time to work it out. Required for libtool.