summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2009-11-16 19:28:07 -0600
committerLaMont Jones <lamont@debian.org>2009-11-16 19:28:07 -0600
commit8326481b01c0e7a76fe04c2ded97d375c319004a (patch)
tree2470e488e2d08798913bf12075657c5c0cecedc9 /configure.in
parentb2492ab7a9f3eb7cc37ac3f1fd6b173979ffd2b0 (diff)
downloadbind9-8326481b01c0e7a76fe04c2ded97d375c319004a.tar.gz
9.7.0b2
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 26 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b36570d8..e815f03b 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ AC_DIVERT_PUSH(1)dnl
esyscmd([sed "s/^/# /" COPYRIGHT])dnl
AC_DIVERT_POP()dnl
-AC_REVISION($Revision: 1.485 $)
+AC_REVISION($Revision: 1.487 $)
AC_INIT(lib/dns/name.c)
AC_PREREQ(2.59)
@@ -666,8 +666,10 @@ esac
else
AC_MSG_RESULT(no)
fi
+ AC_CHECK_FUNCS(EVP_sha256 EVP_sha512)
CFLAGS="$saved_cflags"
LIBS="$saved_libs"
+
;;
esac
@@ -1941,8 +1943,10 @@ int getnameinfo(const struct sockaddr *, socklen_t, char *,
socklen_t, char *, socklen_t, unsigned int);],
[ return (0);],
[AC_MSG_RESULT(socklen_t for buflen; u_int for flags)
- AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t)
- AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, unsigned int)],
+ AC_DEFINE(IRS_GETNAMEINFO_BUFLEN_T, socklen_t,
+ [Define to the buffer length type used by getnameinfo(3).])
+ AC_DEFINE(IRS_GETNAMEINFO_FLAGS_T, unsigned int,
+ [Define to the flags type used by getnameinfo(3).])],
[AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/socket.h>
@@ -2642,6 +2646,25 @@ case "$enable_fixed" in
esac
#
+# Activate "filter-aaaa-on-v4" or not?
+#
+AC_ARG_ENABLE(filter-aaaa,
+ [ --enable-filter-aaaa enable filtering of AAAA records over IPv4
+ [[default=no]]],
+ enable_filter="$enableval",
+ enable_filter="no")
+case "$enable_filter" in
+ yes)
+ AC_DEFINE(ALLOW_FILTER_AAAA_ON_V4, 1,
+ [Define to enable the "filter-aaaa-on-v4" option.])
+ ;;
+ no)
+ ;;
+ *)
+ ;;
+esac
+
+#
# The following sets up how non-blocking i/o is established.
# Sunos, cygwin and solaris 2.x (x<5) require special handling.
#