summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2005-12-22 22:27:55 +0000
committerRoger Leigh <rleigh@debian.org>2005-12-22 22:27:55 +0000
commit5f22d29531f7a6940bca7da363d0d7c65a78e9f2 (patch)
tree4b929aac14419c08a05ffcadb66f0fe7e206d51d /configure.ac
parent7315e4a8c5c5cc0d08fa352de82b31c85e209ffc (diff)
downloadschroot-5f22d29531f7a6940bca7da363d0d7c65a78e9f2.tar.gz
* schroot/sbuild-chroot.h (sbuild::Chroot::format_detail):
template helper class to simplify streaming outout of chroot details. Used by all derived chroot classes. * All Glib string functions have been replaced with the C++ or C99 equivalent. * All uses of g_return[_val]_if_fail have been replaced with conditionals or static assertions. * All Glib logging and message functions have been replaced with the new logging functions and standard C++ streams. * All Glib types have been completely removed, with the exception of one instance of GError, and two uses of GOption. * Support for gtk-doc has been disabled and partially removed. * The dependency upon libsigc++ has been removed. Virtual functions are used instead, which will provide more safety and security. * schroot/sbuild-keyfile.(cc|h): New class sbuild::keyfile, a replacement for GKeyFile. Unlike GKeyFile, it uses templated methods to allow its use with any streamable type, in a type-safe manner. The existing GKeyFile helper functions have been removed. * schroot/sbuild-log.(cc|h): New file: logging functions to replace the Glib print and logging utility functions. Unlike the Glib types, these are based around ostreams. * schroot/sbuild-nostream.(cc|h): New class sbuild::basic_nostream with nostream and wnostream typedefs. This is a "null ostream", which is a bit-bucket stream which discards all input. * schroot/sbuild-types.h: New file: commonly-used types. * Continue purge of Glib.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a2b01e8d..33d2d936 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,21 +49,18 @@ fi
# Checks for programs.
AC_PROG_CXX
+AC_DISABLE_SHARED
AC_PROG_LIBTOOL
AM_GNU_GETTEXT_VERSION([0.14.5])
AM_GNU_GETTEXT([external])
AC_PATH_PROG([RUN_PARTS], [run-parts])
AH_TEMPLATE(RUN_PARTS,, [run-parts binary])
AC_DEFINE_UNQUOTED(RUN_PARTS, ["$RUN_PARTS"], )
-AC_PATH_PROG([GLIB_MKENUMS], [glib-mkenums])
-AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
-GTK_DOC_CHECK([1.2])
# Checks for libraries.
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.4.0])
PKG_CHECK_MODULES([UUID], [uuid])
-PKG_CHECK_MODULES([SIGC], [sigc++-2.0])
-SCHROOT_CFLAGS="$GLIB_CFLAGS $UUID_CFLAGS $SIGC_CFLAGS"
+SCHROOT_CFLAGS="$GLIB_CFLAGS $UUID_CFLAGS"
AC_SUBST([SCHROOT_CFLAGS])
# Checks for header files (none at the moment).