summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2010-06-18 00:08:08 +0100
committerRoger Leigh <rleigh@debian.org>2010-06-18 00:08:08 +0100
commit52be03e85f4907cc7d80af6679341f3ed3c1c9cf (patch)
treea2b0a4b3383ffe0d6e569b9995d7b9b8c5e6417b /debian/rules
parent8f28cac316e7c3dba92afe640d73ec32ba9ad70f (diff)
downloadschroot-52be03e85f4907cc7d80af6679341f3ed3c1c9cf.tar.gz
debian: Enable btrfs-snapshot and lvm-snapshot only on Linux
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 8ba23ed5..2b6d8c16 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,13 @@
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+ifneq ($(DEB_HOST_ARCH_OS),linux)
+ LINUX_CONFIGURE_OPTIONS =
+else
+ LINUX_CONFIGURE_OPTIONS = --enable-lvm-snapshot --enable-btrfs-snapshot
+endif
CFLAGS = -Wall -g
@@ -36,7 +42,8 @@ debian/build/config.status: configure
--enable-dchroot --enable-dchroot-dsa \
--enable-doxygen \
--enable-static --disable-shared \
- --with-bash-completion-dir=/etc/bash_completion.d
+ --with-bash-completion-dir=/etc/bash_completion.d \
+ $(LINUX_CONFIGURE_OPTIONS)
build: build-stamp