summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 947f762..ef13d8c 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -6,18 +6,18 @@ dbusconf_DATA = ConsoleKit.conf
seatdir = $(sysconfdir)/ConsoleKit/seats.d
seat_DATA = 00-primary.seat
-SCRIPT_IN_FILES = ConsoleKit.in
-
-# I guess it's Linux-only but that will do for the moment.
-if ! CK_COMPILE_FREEBSD
-initddir=$(sysconfdir)/rc.d/init.d
-initd_SCRIPTS= \
- ConsoleKit \
+if HAVE_POLKIT
+polkit_policydir = $(datadir)/PolicyKit/policy
+dist_polkit_policy_DATA = \
+ ConsoleKit.policy \
$(NULL)
endif
+servicedir = $(datadir)/dbus-1/system-services
+service_in_files = org.freedesktop.ConsoleKit.service.in
+service_DATA = $(service_in_files:.service.in=.service)
-ConsoleKit: ConsoleKit.in Makefile
+$(service_DATA): $(service_in_files) Makefile
$(edit) $< >$@
edit = sed \
@@ -29,11 +29,11 @@ edit = sed \
EXTRA_DIST = \
$(dbusconf_DATA) \
$(seat_DATA) \
- $(SCRIPT_IN_FILES) \
+ $(service_in_files) \
$(NULL)
MAINTAINERCLEANFILES = \
*~ \
Makefile.in
-CLEANFILES = ConsoleKit
+CLEANFILES = $(service_DATA)