summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/consolekit.install8
-rwxr-xr-xdebian/rules10
3 files changed, 16 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 2c89732..9d010ee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,13 @@ consolekit (0.4.5-3.1) unstable; urgency=low
-- Christoph Egger <christoph@debian.org> Mon, 30 Jul 2012 13:57:55 +0200
+consolekit (0.4.5-3+dyson1) unstable; urgency=low
+
+ * Built for Dyson
+ * Install systemd files only on linux
+
+ -- Igor Pashev <pashev.igor@gmail.com> Fri, 09 Nov 2012 13:28:53 +0000
+
consolekit (0.4.5-3) unstable; urgency=low
* Strip debian/tmp/ from .install files.
diff --git a/debian/consolekit.install b/debian/consolekit.install
index be35036..41dcc23 100644
--- a/debian/consolekit.install
+++ b/debian/consolekit.install
@@ -7,11 +7,3 @@ var/log/ConsoleKit/
usr/sbin/
usr/bin/
debian/90consolekit etc/X11/Xsession.d/
-lib/systemd/system/console-kit-daemon.service
-lib/systemd/system/console-kit-log-system-start.service
-lib/systemd/system/console-kit-log-system-stop.service
-lib/systemd/system/console-kit-log-system-restart.service
-lib/systemd/system/basic.target.wants/console-kit-log-system-start.service
-lib/systemd/system/halt.target.wants/console-kit-log-system-stop.service
-lib/systemd/system/poweroff.target.wants/console-kit-log-system-stop.service
-lib/systemd/system/reboot.target.wants/console-kit-log-system-restart.service
diff --git a/debian/rules b/debian/rules
index 713fe1f..a2937c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,16 @@
#!/usr/bin/make -f
+include /usr/share/dpkg/architecture.mk
+
%:
dh $@ --with autoreconf
+ifeq (linux, $(DEB_HOST_ARCH_OS))
+with-systemd := --with-systemdsystemunitdir=/lib/systemd/system
+else
+with-systemd :=
+endif
+
ifeq ($(DEB_HOST_ARCH_OS),linux)
CONFFLAGS = --enable-udev-acl
endif
@@ -13,7 +21,7 @@ override_dh_auto_configure:
--enable-pam-module \
--enable-docbook-docs \
--with-pid-file=/var/run/console-kit-daemon.pid \
- --with-systemdsystemunitdir=/lib/systemd/system \
+ $(with-systemd) \
--with-pam-module-dir=/lib/$(DEB_HOST_MULTIARCH)/security
override_dh_auto_install: