summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-01-06 17:48:59 +0000
committerSimon McVittie <smcv@debian.org>2011-01-06 17:48:59 +0000
commit227d926b508fc4fa1fec9828998e70b3885bbcb1 (patch)
tree73c5c9285179cd7b7df2dcf9cf07d8b4d5d60ee0
parent7e93583e08e692272ceedc66bf93448acbeb30ac (diff)
downloaddbus-227d926b508fc4fa1fec9828998e70b3885bbcb1.tar.gz
Remove commented-out code from 00_dbus-quiesce-startup-errors.patch and
forward it upstream git-svn-id: svn+ssh://svn.debian.org/svn/pkg-utopia/packages/experimental/dbus@3796 ceb527fc-18e6-0310-9fe2-813c157c29e7
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00_dbus-quiesce-startup-errors.patch25
2 files changed, 22 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index cc29d864..4436af31 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dbus (1.4.1-2) UNRELEASED; urgency=low
+
+ * Remove commented-out code from 00_dbus-quiesce-startup-errors.patch and
+ forward it upstream
+
+ -- Simon McVittie <smcv@debian.org> Thu, 06 Jan 2011 17:43:18 +0000
+
dbus (1.4.1-1) experimental; urgency=low
* New upstream release.
diff --git a/debian/patches/00_dbus-quiesce-startup-errors.patch b/debian/patches/00_dbus-quiesce-startup-errors.patch
index 4144c8a3..32ae83dc 100644
--- a/debian/patches/00_dbus-quiesce-startup-errors.patch
+++ b/debian/patches/00_dbus-quiesce-startup-errors.patch
@@ -1,18 +1,23 @@
-Index: b/bus/config-parser.c
-===================================================================
---- a/bus/config-parser.c 2010-07-14 00:43:38.000000000 +0200
-+++ b/bus/config-parser.c 2010-07-17 15:16:44.226404084 +0200
-@@ -2236,8 +2236,18 @@
+From: Daniel Silverstone <dsilvers@debian.org>
+Date: Tue, 10 Feb 2004 00:46:52 +0000
+Subject: [PATCH] Quiesce error reports in system.d/*.conf files when loading
+
+Bug: https://bugs.freedesktop.org/show_bug.cgi?id=19186
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=230231
+---
+ bus/config-parser.c | 9 +++++++--
+ 1 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/bus/config-parser.c b/bus/config-parser.c
+index f128b91..83dc880 100644
+--- a/bus/config-parser.c
++++ b/bus/config-parser.c
+@@ -2237,8 +2237,13 @@ include_dir (BusConfigParser *parser,
{
if (!include_file (parser, &full_path, TRUE, error))
{
- _dbus_string_free (&full_path);
- goto failed;
-+ /* Debian patch to skip malformed /etc/dbus-1/system.d entries */
-+ /*
-+ * _dbus_string_free (&full_path);
-+ * goto failed;
-+ */
+ if (dbus_error_is_set (error))
+ {
+ _dbus_warn("\nEncountered error '%s' while parsing '%s'\n",