summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-06-13 11:11:31 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-07-18 19:14:55 +0100
commitb354cfc84a2f7ce4f67a32ef7d8ef24d13e8b852 (patch)
treea53619a02be669871ed497e703a7b52d86546ffa
parente07a8f8e4418b8f3598050f03d08ba225aec07d2 (diff)
downloaddbus-b354cfc84a2f7ce4f67a32ef7d8ef24d13e8b852.tar.gz
Run bus tests from test/
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=34405 Reviewed-by: Will Thompson <will.thompson@collabora.co.uk>
-rw-r--r--bus/Makefile.am22
-rw-r--r--test/Makefile.am5
2 files changed, 17 insertions, 10 deletions
diff --git a/bus/Makefile.am b/bus/Makefile.am
index 9761c27c..a3ddb6cf 100644
--- a/bus/Makefile.am
+++ b/bus/Makefile.am
@@ -146,25 +146,27 @@ bus_test_launch_helper_CPPFLAGS= -DDBUS_STATIC_BUILD \
-DACTIVATION_LAUNCHER_TEST \
-DACTIVATION_LAUNCHER_DO_OOM
-## we use noinst_PROGRAMS not check_PROGRAMS so that we build
-## even when not doing "make check"
-noinst_PROGRAMS = $(TESTS)
+noinst_PROGRAMS =
dbus_daemon_exec_PROGRAMS = dbus-daemon
if DBUS_UNIX
libexec_PROGRAMS = dbus-daemon-launch-helper
endif DBUS_UNIX
-## note that TESTS has special meaning (stuff to use in make check)
-## so if adding tests not to be run in make check, don't add them to
-## TESTS
-TESTS =
+## Note that TESTS has special meaning (stuff to use in make check).
+## We don't actually want to run any of these tests until test/ has been
+## compiled, so we don't put them in TESTS here; we run them in test/
+## instead.
if DBUS_BUILD_TESTS
-TESTS_ENVIRONMENT=DBUS_TEST_DATA=$(top_builddir)/test/data DBUS_TEST_HOMEDIR=$(top_builddir)/dbus DBUS_FATAL_WARNINGS=1 DBUS_BLOCK_ON_ABORT=1
-TESTS += bus-test bus-test-system
+## we use noinst_PROGRAMS not check_PROGRAMS so that we build
+## even when not doing "make check"
+
+# run as a test by test/Makefile.am
+noinst_PROGRAMS += bus-test bus-test-system
if DBUS_UNIX
-TESTS += bus-test-launch-helper
+# run as a test by test/Makefile.am
+noinst_PROGRAMS += bus-test-launch-helper
# this is used by the tests but is not,itself, a test
noinst_PROGRAMS += dbus-daemon-launch-helper-test
endif DBUS_UNIX
diff --git a/test/Makefile.am b/test/Makefile.am
index 564300dd..d2a846d0 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -34,6 +34,9 @@ TESTS = \
## order, but we don't want to run them til we arrive in this directory,
## since they depend on stuff from this directory
TESTS += \
+ ../bus/bus-test \
+ ../bus/bus-test-system \
+ ../bus/bus-test-launch-helper \
../dbus/dbus-test \
$(NULL)
@@ -111,6 +114,8 @@ installcheck_environment = \
DBUS_TEST_SYSCONFDIR=$(DESTDIR)$(sysconfdir)
TESTS_ENVIRONMENT = \
+ DBUS_BLOCK_ON_ABORT=1 \
+ DBUS_FATAL_WARNINGS=1 \
DBUS_TEST_DAEMON=@abs_top_builddir@/bus/dbus-daemon$(EXEEXT) \
DBUS_TEST_DATA=@abs_top_builddir@/test/data \
DBUS_TEST_HOMEDIR=@abs_top_builddir@/dbus \