summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2014-01-07 12:49:43 +0000
committerSimon McVittie <smcv@debian.org>2014-01-07 12:49:43 +0000
commit0f4e5e592fbb7cc2ab6fb5d7e3a8e593a90982d9 (patch)
tree3de412631c76c6b1843240a4286785ac78bea8d1
parenteba9d5478ebd6548872e7ac6325aae0ef34fd9d1 (diff)
downloaddbus-0f4e5e592fbb7cc2ab6fb5d7e3a8e593a90982d9.tar.gz
Conditionalize libaudit build-dependency to [linux-any]debian/1.7.10-2
* Explicitly enable libaudit, SELinux and systemd on Linux; do not enable them elsewhere
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules12
3 files changed, 21 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 72d581de..deb048d6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dbus (1.7.10-2) unstable; urgency=low
+
+ * Conditionalize libaudit and libcap-ng build-dependencies to [linux-any]
+ * Explicitly enable libaudit, SELinux and systemd on Linux;
+ do not enable them elsewhere
+
+ -- Simon McVittie <smcv@debian.org> Tue, 07 Jan 2014 12:12:15 +0000
+
dbus (1.7.10-1) unstable; urgency=low
* Merge from experimental into unstable
diff --git a/debian/control b/debian/control
index 799e7723..cfc3cab6 100644
--- a/debian/control
+++ b/debian/control
@@ -30,8 +30,8 @@ Build-Depends: automake (>= 1:1.10),
dh-autoreconf,
doxygen,
dpkg-dev (>= 1.16.1),
- libaudit-dev,
- libcap-ng-dev,
+ libaudit-dev [linux-any],
+ libcap-ng-dev [linux-any],
libexpat-dev,
libdbus-glib-1-dev,
libglib2.0-dev,
diff --git a/debian/rules b/debian/rules
index 91926b53..3d6c28a6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,11 +22,21 @@ dh_options = \
common_configure_flags := \
--disable-silent-rules \
- --enable-libaudit \
--enable-installed-tests \
--libexecdir=\$${prefix}/lib/dbus-1.0 \
+ $(NULL)
+
+ifeq ($(filter stage1,$(DEB_BUILD_PROFILE)),)
+ifeq ($(DEB_HOST_ARCH_OS),linux)
+# Non-bootstrap build on Linux: add Linux-specifics
+common_configure_flags += \
+ --enable-libaudit \
+ --enable-selinux \
+ --enable-systemd \
--with-systemdsystemunitdir=/lib/systemd/system \
$(NULL)
+endif
+endif
normal_configure_flags := \
--libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \