summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-02-13 11:40:25 +0000
committerSimon McVittie <smcv@debian.org>2015-02-13 11:56:31 +0000
commit84215dc7e3fdafe3117d7cd87aeb0b01f10c5190 (patch)
tree6b2d9b08b420a3f6e5bddcdbcf1e3f98530a324b
parentf4ccfe8ab05f02d108914fbf9cc15ed5b1abbafe (diff)
downloaddbus-84215dc7e3fdafe3117d7cd87aeb0b01f10c5190.tar.gz
Replace part of user-bus patch series with a reviewed version
No functional changes.
-rw-r--r--debian/patches/Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch16
-rw-r--r--debian/patches/Add-dbus-update-activation-environment-tool.patch1
-rw-r--r--debian/patches/On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch1
-rw-r--r--debian/patches/Optionally-install-systemd-user-units-for-a-per-user.patch1
-rw-r--r--debian/patches/cope-with-not-having-an-XDG_RUNTIME_DIR-to-restore.patch27
-rw-r--r--debian/patches/series1
6 files changed, 13 insertions, 34 deletions
diff --git a/debian/patches/Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch b/debian/patches/Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch
index aa6f96a0..855f87a9 100644
--- a/debian/patches/Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch
+++ b/debian/patches/Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch
@@ -6,11 +6,12 @@ Subject: Add a regression test for connecting to XDG_RUNTIME_DIR/bus by
This test requires the unix:runtime=yes sub-transport from Bug #61303.
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301
+Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
---
test/Makefile.am | 1 +
.../valid-config-files/listen-unix-runtime.conf | 11 +++
- test/dbus-daemon.c | 78 +++++++++++++++++++++-
- 3 files changed, 87 insertions(+), 3 deletions(-)
+ test/dbus-daemon.c | 81 +++++++++++++++++++++-
+ 3 files changed, 90 insertions(+), 3 deletions(-)
create mode 100644 test/data/valid-config-files/listen-unix-runtime.conf
diff --git a/test/Makefile.am b/test/Makefile.am
@@ -43,7 +44,7 @@ index 0000000..169de2c
+ </policy>
+</busconfig>
diff --git a/test/dbus-daemon.c b/test/dbus-daemon.c
-index 6b0e9b8..3497cc3 100644
+index 6b0e9b8..86163b9 100644
--- a/test/dbus-daemon.c
+++ b/test/dbus-daemon.c
@@ -2,6 +2,7 @@
@@ -129,7 +130,7 @@ index 6b0e9b8..3497cc3 100644
g_free (address);
}
-@@ -593,17 +632,43 @@ teardown (Fixture *f,
+@@ -593,17 +632,46 @@ teardown (Fixture *f,
f->daemon_pid = 0;
}
@@ -145,7 +146,10 @@ index 6b0e9b8..3497cc3 100644
+ g_assert_cmpint (g_rmdir (f->tmp_runtime_dir), ==, 0);
+
+ /* we're relying on being single-threaded for this to be safe */
-+ g_setenv ("XDG_RUNTIME_DIR", f->saved_runtime_dir, TRUE);
++ if (f->saved_runtime_dir != NULL)
++ g_setenv ("XDG_RUNTIME_DIR", f->saved_runtime_dir, TRUE);
++ else
++ g_unsetenv ("XDG_RUNTIME_DIR");
+ g_free (f->saved_runtime_dir);
+ g_free (f->tmp_runtime_dir);
+ }
@@ -175,7 +179,7 @@ index 6b0e9b8..3497cc3 100644
int
main (int argc,
char **argv)
-@@ -621,6 +686,13 @@ main (int argc,
+@@ -621,6 +689,13 @@ main (int argc,
g_test_add ("/processid", Fixture, NULL, setup, test_processid, teardown);
g_test_add ("/canonical-path/uae", Fixture, NULL,
setup, test_canonical_path_uae, teardown);
diff --git a/debian/patches/Add-dbus-update-activation-environment-tool.patch b/debian/patches/Add-dbus-update-activation-environment-tool.patch
index 66b17922..269f4b14 100644
--- a/debian/patches/Add-dbus-update-activation-environment-tool.patch
+++ b/debian/patches/Add-dbus-update-activation-environment-tool.patch
@@ -27,6 +27,7 @@ dbus-x11 eventually becomes a tool for change-averse setups or goes
away entirely.
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301
+Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
---
cmake/doc/CMakeLists.txt | 3 +
cmake/tools/CMakeLists.txt | 10 +
diff --git a/debian/patches/On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch b/debian/patches/On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch
index c6c54526..2c793492 100644
--- a/debian/patches/On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch
+++ b/debian/patches/On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch
@@ -17,6 +17,7 @@ Based on a patch by Colin Walters, with these changes:
- coding style adjustments
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301
+Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
---
dbus/dbus-sysdeps-unix.c | 87 +++++++++++++++++++++++++++++++++++++++++++++---
dbus/dbus-sysdeps-unix.h | 4 +++
diff --git a/debian/patches/Optionally-install-systemd-user-units-for-a-per-user.patch b/debian/patches/Optionally-install-systemd-user-units-for-a-per-user.patch
index 30dc3203..2f9b895f 100644
--- a/debian/patches/Optionally-install-systemd-user-units-for-a-per-user.patch
+++ b/debian/patches/Optionally-install-systemd-user-units-for-a-per-user.patch
@@ -26,6 +26,7 @@ the sysadmin can choose whether to enable the user-session model by
choosing whether to install that package.
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301
+Reviewed-by: Philip Withnall <philip.withnall@collabora.co.uk>
---
bus/Makefile.am | 16 +++++++++++++++-
bus/systemd-user/dbus.service.in | 11 +++++++++++
diff --git a/debian/patches/cope-with-not-having-an-XDG_RUNTIME_DIR-to-restore.patch b/debian/patches/cope-with-not-having-an-XDG_RUNTIME_DIR-to-restore.patch
deleted file mode 100644
index a709031e..00000000
--- a/debian/patches/cope-with-not-having-an-XDG_RUNTIME_DIR-to-restore.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Simon McVittie <simon.mcvittie@collabora.co.uk>
-Date: Thu, 12 Feb 2015 18:25:06 +0000
-Subject: cope with not having an XDG_RUNTIME_DIR to restore
-
-This can happen if running integration tests under sudo.
-
-Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61301
----
- test/dbus-daemon.c | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/test/dbus-daemon.c b/test/dbus-daemon.c
-index 3497cc3..86163b9 100644
---- a/test/dbus-daemon.c
-+++ b/test/dbus-daemon.c
-@@ -644,7 +644,10 @@ teardown (Fixture *f,
- g_assert_cmpint (g_rmdir (f->tmp_runtime_dir), ==, 0);
-
- /* we're relying on being single-threaded for this to be safe */
-- g_setenv ("XDG_RUNTIME_DIR", f->saved_runtime_dir, TRUE);
-+ if (f->saved_runtime_dir != NULL)
-+ g_setenv ("XDG_RUNTIME_DIR", f->saved_runtime_dir, TRUE);
-+ else
-+ g_unsetenv ("XDG_RUNTIME_DIR");
- g_free (f->saved_runtime_dir);
- g_free (f->tmp_runtime_dir);
- }
diff --git a/debian/patches/series b/debian/patches/series
index f8073cf9..c522f444 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,7 +6,6 @@ Add-regression-test-for-unix-runtime-yes.patch
loopback-test-cope-with-being-run-without-XDG_RUNTIM.patch
On-Unix-platforms-try-XDG_RUNTIME_DIR-bus-before-def.patch
Add-a-regression-test-for-connecting-to-XDG_RUNTIME_.patch
-cope-with-not-having-an-XDG_RUNTIME_DIR-to-restore.patch
Optionally-install-systemd-user-units-for-a-per-user.patch
Add-dbus-update-activation-environment-tool.patch
Don-t-abort-on-fatal-warnings-by-default.patch