summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2015-02-03 21:39:25 +0000
committerSimon McVittie <smcv@debian.org>2015-02-03 21:39:25 +0000
commitd7cd12f5e765a4eda4612708ba89e04ed8b33cb4 (patch)
tree7e59484e07ef797d42d69622f34b74f00a5f3f5d
parentd51665cacd45aebae9dd3329d37db17c32fa784b (diff)
downloaddbus-debian/1.9.8-1.tar.gz
New upstream release with GNOME-style installed testsdebian/1.9.8-1
- run the tests through gnome-desktop-testing-runner - also continue to run the tests the old way to make sure there are no regressions - also run one test as root to verify behaviour with multiple uids - dbus-1-dbg is temporarily not Multi-Arch: same (until we split out dbus-1-tests, which will require a trip through the NEW queue)
-rw-r--r--debian/changelog13
-rw-r--r--debian/control1
-rw-r--r--debian/dbus-1-dbg.install4
-rwxr-xr-xdebian/rules16
-rw-r--r--debian/tests/control9
-rwxr-xr-xdebian/tests/gnome-desktop-testing12
-rwxr-xr-xdebian/tests/installed-tests2
-rwxr-xr-xdebian/tests/root39
8 files changed, 85 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 6168db4c..7a11fef3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,17 @@
-dbus (1.9.6-2) UNRELEASED; urgency=medium
+dbus (1.9.8-1) experimental; urgency=medium
* Merge from unstable
- relax the triggers from interest to interest-noawait (Closes: #771989;
mitigates: #776063; partially reopens: #740139), see below
-
- -- Simon McVittie <smcv@debian.org> Tue, 03 Feb 2015 17:37:37 +0000
+ * New upstream release with GNOME-style installed tests
+ - run the tests through gnome-desktop-testing-runner
+ - also continue to run the tests the old way to make sure there are
+ no regressions
+ - also run one test as root to verify behaviour with multiple uids
+ - dbus-1-dbg is temporarily not Multi-Arch: same (until we split out
+ dbus-1-tests, which will require a trip through the NEW queue)
+
+ -- Simon McVittie <smcv@debian.org> Tue, 03 Feb 2015 21:34:57 +0000
dbus (1.8.14-2) unstable; urgency=high
diff --git a/debian/control b/debian/control
index 1f0d1fe2..5e544459 100644
--- a/debian/control
+++ b/debian/control
@@ -179,7 +179,6 @@ Description: simple interprocess messaging system (development headers)
Package: dbus-1-dbg
Section: debug
Priority: extra
-Multi-Arch: same
Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends: libdbus-1-3 (= ${binary:Version}),
diff --git a/debian/dbus-1-dbg.install b/debian/dbus-1-dbg.install
index 2734d21f..6014da67 100644
--- a/debian/dbus-1-dbg.install
+++ b/debian/dbus-1-dbg.install
@@ -1,3 +1,5 @@
-debian/tmp/usr/lib/*/dbus-1.0/test
+debian/tmp/usr/share/installed-tests
+debian/tmp/usr/lib/dbus-1.0/installed-tests
debian/tmp/usr/lib/*/dbus-1.0/debug-build/bin
debian/tmp/usr/lib/*/dbus-1.0/debug-build/lib
+debian/tmp/usr/lib/*/dbus-1.0/debug-build/share/installed-tests/dbus usr/share/installed-tests/dbus-debug-build
diff --git a/debian/rules b/debian/rules
index d53ace15..ed57c127 100755
--- a/debian/rules
+++ b/debian/rules
@@ -133,8 +133,16 @@ override_dh_auto_test:
override_dh_auto_install:
dh_auto_install
- make -C build-debug install-exec DESTDIR=$(CURDIR)/debian/tmp
+ make -C build-debug install DESTDIR=$(CURDIR)/debian/tmp-debug
make -C build-udeb install-exec DESTDIR=$(CURDIR)/debian/tmp-udeb
+ rm -rf debian/tmp-debug/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/include
+ rm -rf debian/tmp-debug/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/lib/dbus-1.0/include
+ rm -rf debian/tmp-debug/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/share/doc
+ mv debian/tmp-debug/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build \
+ debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build
+ rm -rfv debian/tmp-debug
+ rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libdbus-1.la
+ rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/lib/libdbus-1.la
override_dh_link:
dh_link -plibdbus-1-dev lib/$(DEB_HOST_MULTIARCH)/$$(basename $$(readlink debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libdbus-1.so)) usr/lib/$(DEB_HOST_MULTIARCH)/libdbus-1.so
@@ -144,9 +152,8 @@ override_dh_link:
# the directory in case that's happened, so the .install file doesn't need
# modification
override_dh_install:
- install -d debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/test
- rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libdbus-1.la
- rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/lib/libdbus-1.la
+ install -d debian/tmp/usr/lib/dbus-1.0/installed-tests/dbus
+ install -d debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/dbus-1.0/debug-build/lib/dbus-1.0/installed-tests/dbus
dh_install -p$(libdbusN) \
"usr/lib/$(DEB_HOST_MULTIARCH)/$(libdbus_soname)*" \
lib/$(DEB_HOST_MULTIARCH)
@@ -195,4 +202,5 @@ override_dh_auto_clean:
clean:
rm -rf debian/tmp-udeb
+ rm -rf debian/tmp-debug
dh $@ $(dh_options)
diff --git a/debian/tests/control b/debian/tests/control
index 0515c14b..3577911f 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,5 +1,12 @@
Tests: installed-tests
-Depends: dbus, libdbus-1-3, dbus-1-dbg
+Depends: dbus, dbus-1-dbg
+
+Tests: gnome-desktop-testing
+Depends: dbus, dbus-1-dbg, gnome-desktop-testing
+
+Tests: root
+Restrictions: needs-root
+Depends: dbus, dbus-1-dbg
Tests: build
Depends: libdbus-1-dev, dbus, build-essential
diff --git a/debian/tests/gnome-desktop-testing b/debian/tests/gnome-desktop-testing
new file mode 100755
index 00000000..615a8bf7
--- /dev/null
+++ b/debian/tests/gnome-desktop-testing
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+set -e
+
+unset DISPLAY
+
+DBUS_TEST_HOMEDIR="$ADTTMP"
+export DBUS_TEST_HOMEDIR
+
+exec 2>&1
+
+exec gnome-desktop-testing-runner dbus
diff --git a/debian/tests/installed-tests b/debian/tests/installed-tests
index 9f1be3ec..a34a5d3c 100755
--- a/debian/tests/installed-tests
+++ b/debian/tests/installed-tests
@@ -7,7 +7,7 @@ timeout="timeout 300s"
ret=0
i=0
-for dir in /usr/lib/*/dbus-1.0/test /usr/lib/*/dbus-1.0/debug-build/lib/dbus-1.0/test; do
+for dir in /usr/lib/dbus-1.0/installed-tests/dbus /usr/lib/*/dbus-1.0/debug-build/lib/dbus-1.0/installed-tests/dbus; do
for t in "$dir"/test-*; do
i=$(( $i + 1 ))
echo "# $i - $t ..."
diff --git a/debian/tests/root b/debian/tests/root
new file mode 100755
index 00000000..ceab6dc8
--- /dev/null
+++ b/debian/tests/root
@@ -0,0 +1,39 @@
+#!/bin/sh
+# Run some tests as root. Output TAP format because why not
+
+set -e
+
+timeout="timeout 300s"
+ret=0
+i=0
+
+for d in /usr/lib/dbus-1.0/installed-tests/dbus \
+ /usr/lib/*/dbus-1.0/debug-build/lib/dbus-1.0/installed-tests/dbus
+do
+ DBUS_TEST_DATA="$d/data"
+ export DBUS_TEST_DATA
+
+ for t in $d/test-uid-permissions
+ do
+ i=$(( $i + 1 ))
+ echo "# $i - $t ..."
+ echo "x" > "$ADTTMP/result"
+ ( set +e; $timeout $t; echo "$?" > "$ADTTMP/result" ) 2>&1 | sed 's/^/# /'
+ e="$(cat "$ADTTMP/result")"
+ case "$e" in
+ (0)
+ echo "ok $i - $t"
+ ;;
+ (77)
+ echo "ok $i # SKIP $t"
+ ;;
+ (*)
+ echo "not ok $i - $t ($e)"
+ ret=1
+ ;;
+ esac
+ done
+done
+
+echo "1..$i"
+exit $ret