summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-02-17 18:28:14 +0000
committerSimon McVittie <smcv@debian.org>2011-02-17 18:28:14 +0000
commit280851b7fdb7050e42403f57cbbbdbc368e59efa (patch)
tree1e0221b28d8a496eee7894c9776eeb84966168cb /Makefile.am
parent7e5f91a2e50af075be865533eb6ebdfe6bc5b4ad (diff)
downloaddbus-280851b7fdb7050e42403f57cbbbdbc368e59efa.tar.gz
Imported Upstream version 1.4.4upstream/1.4.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 6 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ce8d5b0..ac7dcb15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,51 +15,14 @@ EXTRA_DIST = \
NEWS.pre-1-0 \
ChangeLog.pre-1-2 \
NEWS.pre-1-2 \
- README.win \
+ README.win \
+ README.wince \
+ README.cygwin \
+ README.launchd \
cmake
all-local: Doxyfile
-if DBUS_GCOV_ENABLED
-clean-gcov:
- find -name "*.da" -o -name "*.gcov" | xargs rm || true
-
-clean-bbg:
- find -name "*.bbg" -o -name "*.bb" | xargs rm || true
-
-GCOV_DIRS=dbus bus
-
-## .PHONY so it always rebuilds it
-.PHONY: coverage-report.txt
-coverage-report.txt:
- BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg" -o -name "*.gcno"` ; \
- C_FILES= ; \
- for F in $$BBG_FILES ; do \
- F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
- C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g' | sed -e 's/.gcno/.c/g'` ; \
- B=`basename $$F .bbg` ; \
- D=`dirname $$F` ; \
- DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
- DA_libs=`echo $$D/.libs/$$B/.da` ; \
- if test -e $$DA || test -e $$DA_libs; then \
- C_FILES="$$C_FILES $$C" ; \
- fi ; \
- done ; \
- echo $$C_FILES ; \
- $(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
-
-check-coverage: clean-gcov all check coverage-report.txt
- cat coverage-report.txt
-
-else
-coverage-report.txt:
- echo "Need to reconfigure with --enable-gcov"
-
-check-coverage:
- echo "Need to reconfigure with --enable-gcov"
-
-endif
-
update-authors:
git shortlog -s -e | cut -c 8- | sort > AUTHORS
@@ -67,3 +30,5 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
ACLOCAL_AMFLAGS = -I m4
+
+include tools/lcov.am