summaryrefslogtreecommitdiff
path: root/cmake
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2013-04-18 12:21:58 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-04-18 19:21:18 +0100
commit1502908465491df129ca2b101bf528e0a9a6fb57 (patch)
tree608b355a4456f9fb1d360f4df44f8bac378a360f /cmake
parent68c1a26d1e740e2500001b4a28d91d5753fc99dc (diff)
downloaddbus-1502908465491df129ca2b101bf528e0a9a6fb57.tar.gz
cmake: define default_message_unix_fds so it can be substituted in session.conf
This fixes a regression since 1.7.0: session.conf would be invalid when generated by cmake. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=63682 Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'cmake')
-rw-r--r--cmake/CMakeLists.txt4
-rw-r--r--cmake/config.h.cmake2
2 files changed, 5 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 9a37e40f..c7f9939e 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -435,6 +435,10 @@ endif (WIN32)
set (DBUS_USER )
+# In Autotools this has a different default on QNX, but there seems little
+# point in replicating that here; if you're on an unusual Unix, use Autotools.
+set (default_message_unix_fds 1024)
+
# This won't work on Windows. It's not meant to - the system bus is
# meaningless on Windows anyway.
#
diff --git a/cmake/config.h.cmake b/cmake/config.h.cmake
index b0dde3dd..3c7cb966 100644
--- a/cmake/config.h.cmake
+++ b/cmake/config.h.cmake
@@ -82,7 +82,7 @@
# define DBUS_ENABLE_X11_AUTOLAUNCH 1
#endif
-#define DBUS_DEFAULT_MESSAGE_UNIX_FDS 1024
+#define DBUS_DEFAULT_MESSAGE_UNIX_FDS @default_message_unix_fds@
#define _DBUS_VA_COPY_ASSIGN(a1,a2) { a1 = a2; }