summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-06-27 12:56:20 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-08-22 20:03:06 +0100
commit014ea556251259cd3c6965b78b42ebb903291e77 (patch)
tree8e27f8ff3d7ffebc76ec54fa3c3920c01f97367e /configure.ac
parent15bc915d7469233eeed997044f79bd619b62bd4e (diff)
downloaddbus-014ea556251259cd3c6965b78b42ebb903291e77.tar.gz
Ignore more unused staff if build with tests but without asserts
https://bugs.freedesktop.org/show_bug.cgi?id=66069 Signed-off-by: Chengwei Yang <chengwei.yang@intel.com> Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c80fcfcb..8caea402 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,6 +273,11 @@ if test x$enable_asserts = xno; then
AC_DEFINE(DBUS_DISABLE_ASSERT,1,[Disable assertion checking])
DISABLE_UNUSED_WARNINGS="unused-label"
R_DYNAMIC_LDFLAG=""
+ if test x$enable_embedded_tests = xyes; then
+ DISABLE_UNUSED_WARNINGS="$DISABLE_UNUSED_WARNINGS \
+ unused-but-set-variable unused-variable \
+ unused-function"
+ fi
else
# -rdynamic is needed for glibc's backtrace_symbols to work.
# No clue how much overhead this adds, but it's useful