summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2013-03-08 13:55:32 +0100
committerRalf Habacker <ralf.habacker@sag.eu>2013-04-05 11:17:26 +0200
commit8159956ed4d34ff217f67758a72005fe4362aa45 (patch)
tree943f5bc5b46f85d2523dadf8c424b9ba9f92b7cd /configure.ac
parent89c1ecdd7cdd6c836506065a47bfb47d20bbb874 (diff)
downloaddbus-8159956ed4d34ff217f67758a72005fe4362aa45.tar.gz
Add function _dbus_get_peer_pid_from_tcp_handle() which returns pid and sid from tcp connection peer.
This function is called by _dbus_read_credentials_socket() to fetch client credentials. Because Wine is used to check cross compiled dbus for windows, in calls to GetExtendedTcpTable() we use table class TCP_TABLE_OWNER_PID_ALL instead of TCP_TABLE_OWNER_PID_CONNECTIONS. This class is the only one which is available since wine 1.5.3. https://bugs.freedesktop.org/show_bug.cgi?id=61787 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3bd2405e..b6430c52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1279,7 +1279,7 @@ if test x$dbus_win = xyes ; then
if test x$dbus_wince = xyes ; then
NETWORK_libs="-lws2"
else
- NETWORK_libs="-lws2_32"
+ NETWORK_libs="-lws2_32 -liphlpapi"
fi
fi