summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2014-11-06 14:24:14 +0000
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-01-27 14:29:59 +0000
commit04056bba4143f516fb58045fa48a733a0711f1c8 (patch)
treef607f71a110d321024bcc2430103597da27d9a3d /configure.ac
parent180f3a80617b7579b6fe3711661f343d4e8f44d4 (diff)
downloaddbus-04056bba4143f516fb58045fa48a733a0711f1c8.tar.gz
Use pygi instead of pygobject 2
pygobject 2 is obsolete and unmaintained, and anyway this is for optional functionality (full regression test coverage) rather than anything that will be needed in production builds. Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=85969
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 70d31b7e..aab78c65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -263,14 +263,14 @@ AM_CONDITIONAL([DBUS_ENABLE_INSTALLED_TESTS],
if test "x$enable_tests" = xyes; then
# full test coverage is required, Python is a hard dependency
- AC_MSG_NOTICE([Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygobject])
+ AC_MSG_NOTICE([Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygi])
AM_PATH_PYTHON([2.6])
AC_MSG_CHECKING([for Python modules for full test coverage])
- if "$PYTHON" -c "import dbus, gobject, dbus.mainloop.glib"; then
+ if "$PYTHON" -c "import dbus, gi.repository.GObject, dbus.mainloop.glib"; then
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
- AC_MSG_ERROR([cannot import dbus, gobject, dbus.mainloop.glib Python modules])
+ AC_MSG_ERROR([cannot import dbus, gi.repository.GObject, dbus.mainloop.glib Python modules])
fi
else
# --enable-tests not given: do not abort if Python is missing