summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2014-09-15 11:50:48 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2014-09-15 11:50:48 +0100
commitae50d46ff26de73ec5f8390abcca879340cb0962 (patch)
tree3644d29665f3fadd0d686d08dbfa74eb9e95fa8a /configure.ac
parent467f7a6d426a37ddc0f9401f592facad3d003dfa (diff)
downloaddbus-ae50d46ff26de73ec5f8390abcca879340cb0962.tar.gz
On Linux, call prctl to disable core dumps
Whenever I forget to turn off corekeeper, the regression tests take ages to record all test-segfault's crashes. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=83772 Reviewed-by: Alban Crequy <alban.crequy@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7b91bec..c41426f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -598,6 +598,10 @@ if test "x$ac_cv_header_syslog_h" = "xyes"; then
AC_CHECK_DECLS([LOG_PERROR], [], [], [[#include <syslog.h>]])
fi
+# For test-segfault.c
+AC_CHECK_HEADERS_ONCE([sys/prctl.h])
+AC_CHECK_FUNCS_ONCE([prctl raise])
+
#### Check for broken poll; taken from Glib's configure
AC_MSG_CHECKING([for broken poll])