summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-06-01 16:31:11 +0100
committerSimon McVittie <smcv@debian.org>2011-06-01 16:31:11 +0100
commit8452b2beee58590f7f5047dbef7292b1d702d891 (patch)
tree9cab065c9b29e9aa358bf4f54c0ebba482168cdf /test
parent3e6b351f189f89af76fe1fd6e63a5171fae18284 (diff)
downloaddbus-8452b2beee58590f7f5047dbef7292b1d702d891.tar.gz
Imported Upstream version 1.5.2upstream/1.5.2
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.in13
-rw-r--r--test/data/valid-config-files/tiny-incoming-limit.conf18
-rw-r--r--test/name-test/Makefile.in13
-rw-r--r--test/name-test/test-autolaunch.c19
4 files changed, 31 insertions, 32 deletions
diff --git a/test/Makefile.in b/test/Makefile.in
index fe81e8b0..2c9fbd17 100644
--- a/test/Makefile.in
+++ b/test/Makefile.in
@@ -44,7 +44,9 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/as-ac-expand.m4 \
$(top_srcdir)/m4/compiler.m4 $(top_srcdir)/m4/libtool.m4 \
$(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
$(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/tp-compiler-flag.m4 \
+ $(top_srcdir)/m4/tp-compiler-warnings.m4 \
+ $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
@@ -244,6 +246,7 @@ DBUS_X_CFLAGS = @DBUS_X_CFLAGS@
DBUS_X_LIBS = @DBUS_X_LIBS@
DEFS = @DEFS@
DEPDIR = @DEPDIR@
+DLLTOOL = @DLLTOOL@
DOXYGEN = @DOXYGEN@
DSYMUTIL = @DSYMUTIL@
DUMPBIN = @DUMPBIN@
@@ -285,6 +288,7 @@ LT_REVISION = @LT_REVISION@
MAINT = @MAINT@
MAKEINFO = @MAKEINFO@
MAN2HTML = @MAN2HTML@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
NM = @NM@
NMEDIT = @NMEDIT@
@@ -300,15 +304,10 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
-PIC_CFLAGS = @PIC_CFLAGS@
-PIC_LDFLAGS = @PIC_LDFLAGS@
-PIE_CFLAGS = @PIE_CFLAGS@
-PIE_LDFLAGS = @PIE_LDFLAGS@
PKG_CONFIG = @PKG_CONFIG@
RANLIB = @RANLIB@
RC = @RC@
R_DYNAMIC_LDFLAG = @R_DYNAMIC_LDFLAG@
-SECTION_FLAGS = @SECTION_FLAGS@
SECTION_LDFLAGS = @SECTION_LDFLAGS@
SED = @SED@
SET_MAKE = @SET_MAKE@
@@ -340,6 +339,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
@@ -373,7 +373,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
diff --git a/test/data/valid-config-files/tiny-incoming-limit.conf b/test/data/valid-config-files/tiny-incoming-limit.conf
deleted file mode 100644
index abfab3f7..00000000
--- a/test/data/valid-config-files/tiny-incoming-limit.conf
+++ /dev/null
@@ -1,18 +0,0 @@
-<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
- <!-- Our well-known bus type, don't change this -->
- <type>session</type>
- <listen>unix:tmpdir=/tmp</listen>
-
- <policy context="default">
- <!-- Allow everything to be sent -->
- <allow send_destination="*" eavesdrop="true"/>
- <!-- Allow everything to be received -->
- <allow eavesdrop="true"/>
- <!-- Allow anyone to own anything -->
- <allow own="*"/>
- </policy>
-
- <limit name="max_incoming_bytes">1</limit>
-</busconfig>
diff --git a/test/name-test/Makefile.in b/test/name-test/Makefile.in
index 46b47bba..d08ff3a3 100644
--- a/test/name-test/Makefile.in
+++ b/test/name-test/Makefile.in
@@ -51,7 +51,9 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/as-ac-expand.m4 \
$(top_srcdir)/m4/compiler.m4 $(top_srcdir)/m4/libtool.m4 \
$(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
$(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/configure.ac
+ $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/tp-compiler-flag.m4 \
+ $(top_srcdir)/m4/tp-compiler-warnings.m4 \
+ $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
@@ -245,6 +247,7 @@ DBUS_X_CFLAGS = @DBUS_X_CFLAGS@
DBUS_X_LIBS = @DBUS_X_LIBS@
DEFS = @DEFS@
DEPDIR = @DEPDIR@
+DLLTOOL = @DLLTOOL@
DOXYGEN = @DOXYGEN@
DSYMUTIL = @DSYMUTIL@
DUMPBIN = @DUMPBIN@
@@ -286,6 +289,7 @@ LT_REVISION = @LT_REVISION@
MAINT = @MAINT@
MAKEINFO = @MAKEINFO@
MAN2HTML = @MAN2HTML@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
NM = @NM@
NMEDIT = @NMEDIT@
@@ -301,15 +305,10 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
-PIC_CFLAGS = @PIC_CFLAGS@
-PIC_LDFLAGS = @PIC_LDFLAGS@
-PIE_CFLAGS = @PIE_CFLAGS@
-PIE_LDFLAGS = @PIE_LDFLAGS@
PKG_CONFIG = @PKG_CONFIG@
RANLIB = @RANLIB@
RC = @RC@
R_DYNAMIC_LDFLAG = @R_DYNAMIC_LDFLAG@
-SECTION_FLAGS = @SECTION_FLAGS@
SECTION_LDFLAGS = @SECTION_LDFLAGS@
SED = @SED@
SET_MAKE = @SET_MAKE@
@@ -341,6 +340,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
@@ -374,7 +374,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
diff --git a/test/name-test/test-autolaunch.c b/test/name-test/test-autolaunch.c
index d3f42e35..5e519895 100644
--- a/test/name-test/test-autolaunch.c
+++ b/test/name-test/test-autolaunch.c
@@ -19,6 +19,8 @@ main (int argc, char *argv[])
dbus_error_init (&error);
conn = dbus_bus_get (DBUS_BUS_SESSION, &error);
+
+#ifdef DBUS_ENABLE_X11_AUTOLAUNCH
if (dbus_error_is_set (&error))
{
fprintf (stderr, "*** Failed to autolaunch session bus: %s\n",
@@ -26,6 +28,23 @@ main (int argc, char *argv[])
dbus_error_free (&error);
return 1;
}
+#else
+ /* We don't necessarily expect it to *work* without X (although it might -
+ * for instance on Mac OS it might have used launchd). Just check that the
+ * results are consistent. */
+
+ if (dbus_error_is_set (&error) && conn != NULL)
+ {
+ fprintf (stderr, "*** Autolaunched session bus, but an error was set!\n");
+ return 1;
+ }
+#endif
+
+ if (!dbus_error_is_set (&error) && conn == NULL)
+ {
+ fprintf (stderr, "*** Failed to autolaunch session bus but no error was set\n");
+ return 1;
+ }
return 0;
}