summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2012-06-05 13:39:38 +0100
committerSimon McVittie <smcv@debian.org>2012-06-05 13:39:38 +0100
commit5f8487730b96ad8d44f02d1a3aa74a6cceaf72b6 (patch)
tree3f5a60eb5b9f3b103ddb1287cafba2c61654af61 /test
parentec3035d8c25b7799fbe79a5caaa9d84bdbaca346 (diff)
downloaddbus-5f8487730b96ad8d44f02d1a3aa74a6cceaf72b6.tar.gz
Imported Upstream version 1.6.0upstream/1.6.0
Diffstat (limited to 'test')
-rw-r--r--test/Makefile.am15
-rw-r--r--test/Makefile.in55
-rw-r--r--test/name-test/Makefile.in24
-rw-r--r--test/name-test/test-pending-call-dispatch.c4
-rw-r--r--test/name-test/test-pending-call-timeout.c4
5 files changed, 74 insertions, 28 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 88a0e8cd..aa04792b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -287,14 +287,15 @@ EXTRA_DIST += $(static_data)
## copy tests to builddir so that generated tests and static tests
## are all in one place.
all-local:
- $(AM_V_at)$(INSTALL) -d data/valid-config-files/session.d
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files/session.d
$(AM_V_at)set -e && \
if test $(srcdir) = . || test $(srcdir) -ef .; then \
echo '-- No need to copy test data as srcdir = builddir'; \
else \
for F in $(static_data); do \
- $(INSTALL) -d $${F%/*}; \
- $(INSTALL_DATA) $(srcdir)/$$F $$F; \
+ $(MKDIR_P) $${F%/*}; \
+ rm -f $$F; \
+ cp $(srcdir)/$$F $$F; \
done; \
fi
@@ -315,9 +316,9 @@ noinst_DATA = $(imported_data)
CLEANFILES = $(noinst_DATA)
data/valid-config-files/session.conf: $(top_builddir)/bus/session.conf
- $(AM_V_at)$(INSTALL) -d data/valid-config-files
- $(AM_V_GEN)$(INSTALL_DATA) $< $@
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files
+ $(AM_V_GEN)cp $< $@
data/valid-config-files/system.conf: $(top_builddir)/bus/system.conf
- $(AM_V_at)$(INSTALL) -d data/valid-config-files
- $(AM_V_GEN)$(INSTALL_DATA) $< $@
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files
+ $(AM_V_GEN)cp $< $@
diff --git a/test/Makefile.in b/test/Makefile.in
index d833edce..6fa2974f 100644
--- a/test/Makefile.in
+++ b/test/Makefile.in
@@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.11.3 from Makefile.am.
+# Makefile.in generated by automake 1.11.5 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
@@ -18,6 +18,23 @@
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -217,6 +234,11 @@ RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
install-pdf-recursive install-ps-recursive install-recursive \
installcheck-recursive installdirs-recursive pdf-recursive \
ps-recursive uninstall-recursive
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
DATA = $(noinst_DATA)
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
distclean-recursive maintainer-clean-recursive
@@ -727,8 +749,11 @@ clean-noinstPROGRAMS:
rm -f $$list
install-testexecPROGRAMS: $(testexec_PROGRAMS)
@$(NORMAL_INSTALL)
- test -z "$(testexecdir)" || $(MKDIR_P) "$(DESTDIR)$(testexecdir)"
@list='$(testexec_PROGRAMS)'; test -n "$(testexecdir)" || list=; \
+ if test -n "$$list"; then \
+ echo " $(MKDIR_P) '$(DESTDIR)$(testexecdir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(testexecdir)" || exit 1; \
+ fi; \
for p in $$list; do echo "$$p $$p"; done | \
sed 's/$(EXEEXT)$$//' | \
while read p p1; do if test -f $$p || test -f $$p1; \
@@ -1251,13 +1276,10 @@ distdir: $(DISTFILES)
done
@list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
if test "$$subdir" = .; then :; else \
- test -d "$(distdir)/$$subdir" \
- || $(MKDIR_P) "$(distdir)/$$subdir" \
- || exit 1; \
- fi; \
- done
- @list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
- if test "$$subdir" = .; then :; else \
+ $(am__make_dryrun) \
+ || test -d "$(distdir)/$$subdir" \
+ || $(MKDIR_P) "$(distdir)/$$subdir" \
+ || exit 1; \
dir1=$$subdir; dir2="$(distdir)/$$subdir"; \
$(am__relativize); \
new_distdir=$$reldir; \
@@ -1424,14 +1446,15 @@ installcheck-local:
@DBUS_ENABLE_INSTALLED_TESTS_TRUE@ $(testexec_PROGRAMS)
all-local:
- $(AM_V_at)$(INSTALL) -d data/valid-config-files/session.d
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files/session.d
$(AM_V_at)set -e && \
if test $(srcdir) = . || test $(srcdir) -ef .; then \
echo '-- No need to copy test data as srcdir = builddir'; \
else \
for F in $(static_data); do \
- $(INSTALL) -d $${F%/*}; \
- $(INSTALL_DATA) $(srcdir)/$$F $$F; \
+ $(MKDIR_P) $${F%/*}; \
+ rm -f $$F; \
+ cp $(srcdir)/$$F $$F; \
done; \
fi
@@ -1443,12 +1466,12 @@ clean-local:
fi
data/valid-config-files/session.conf: $(top_builddir)/bus/session.conf
- $(AM_V_at)$(INSTALL) -d data/valid-config-files
- $(AM_V_GEN)$(INSTALL_DATA) $< $@
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files
+ $(AM_V_GEN)cp $< $@
data/valid-config-files/system.conf: $(top_builddir)/bus/system.conf
- $(AM_V_at)$(INSTALL) -d data/valid-config-files
- $(AM_V_GEN)$(INSTALL_DATA) $< $@
+ $(AM_V_at)$(MKDIR_P) data/valid-config-files
+ $(AM_V_GEN)cp $< $@
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/test/name-test/Makefile.in b/test/name-test/Makefile.in
index f7a5e61c..89346094 100644
--- a/test/name-test/Makefile.in
+++ b/test/name-test/Makefile.in
@@ -1,4 +1,4 @@
-# Makefile.in generated by automake 1.11.3 from Makefile.am.
+# Makefile.in generated by automake 1.11.5 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
@@ -16,6 +16,23 @@
@SET_MAKE@
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -127,6 +144,11 @@ DIST_SOURCES = test-autolaunch.c test-ids.c \
test-pending-call-dispatch.c test-pending-call-timeout.c \
test-privserver.c test-privserver-client.c test-shutdown.c \
test-threads-init.c
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
ETAGS = etags
CTAGS = ctags
am__tty_colors = \
diff --git a/test/name-test/test-pending-call-dispatch.c b/test/name-test/test-pending-call-dispatch.c
index 57582d49..c8b5a467 100644
--- a/test/name-test/test-pending-call-dispatch.c
+++ b/test/name-test/test-pending-call-dispatch.c
@@ -98,9 +98,9 @@ main (int argc, char *argv[])
{
long delta;
- _dbus_get_current_time (&start_tv_sec, &start_tv_usec);
+ _dbus_get_monotonic_time (&start_tv_sec, &start_tv_usec);
_run_iteration (conn);
- _dbus_get_current_time (&end_tv_sec, &end_tv_usec);
+ _dbus_get_monotonic_time (&end_tv_sec, &end_tv_usec);
/* we just care about seconds */
delta = end_tv_sec - start_tv_sec;
diff --git a/test/name-test/test-pending-call-timeout.c b/test/name-test/test-pending-call-timeout.c
index 381113bd..d051faba 100644
--- a/test/name-test/test-pending-call-timeout.c
+++ b/test/name-test/test-pending-call-timeout.c
@@ -82,9 +82,9 @@ main (int argc, char *argv[])
{
long delta;
- _dbus_get_current_time (&start_tv_sec, &start_tv_usec);
+ _dbus_get_monotonic_time (&start_tv_sec, &start_tv_usec);
_run_iteration (conn);
- _dbus_get_current_time (&end_tv_sec, &end_tv_usec);
+ _dbus_get_monotonic_time (&end_tv_sec, &end_tv_usec);
/* we just care about seconds */
delta = end_tv_sec - start_tv_sec;