summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--debian/dbus.postinst3
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f53fcc50..f957aa0f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dbus (1.5.2-2) UNRELEASED; urgency=low
* Merge from unstable
* Merge and adapt from Ubuntu:
- create, chown messagebus' home directory in postinst
+ - run dbus-uuidgen --ensure in postinst
-- Simon McVittie <smcv@debian.org> Thu, 02 Jun 2011 17:37:24 +0100
diff --git a/debian/dbus.postinst b/debian/dbus.postinst
index 86150910..0cfb8094 100644
--- a/debian/dbus.postinst
+++ b/debian/dbus.postinst
@@ -22,6 +22,9 @@ if [ "$1" = configure ]; then
chown root:"$MESSAGEUSER" "$LAUNCHER"
chmod 4754 "$LAUNCHER"
fi
+
+ # this is idempotent, the init script also does it
+ dbus-uuidgen --ensure
fi
# Remove stop symlinks for runlevel 1 as killprocs already does the job for us.