summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/dbus.postinst18
2 files changed, 20 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index fad31162..f4cad88a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -20,6 +20,11 @@ dbus (1.2.24-2) UNRELEASED; urgency=low
- Stop restarting dependent services. It was an ugly hack anyway and if
people want to restart dbus, they need take care of that themselves.
(Closes: #540693, #530395)
+ * debian/dbus.postinst
+ - Stop restarting dbus system bus on upgrades as it breaks too many
+ applications and is not supported by upstream in a sensible way.
+ Instead trigger a reboot-required message using update-notifier.
+ (Closes: #530000, #573386)
-- Michael Biebl <biebl@debian.org> Thu, 15 Jul 2010 01:10:46 +0200
diff --git a/debian/dbus.postinst b/debian/dbus.postinst
index bdac3426..77863ffe 100644
--- a/debian/dbus.postinst
+++ b/debian/dbus.postinst
@@ -37,9 +37,21 @@ if [ "$1" = configure ] && dpkg --compare-versions "$2" lt-nl 1.2.24-1; then
fi
if [ "$1" = configure ] && [ -n "$2" ] && [ -x "/etc/init.d/dbus" ]; then
- # Restart dbus on upgrades.
- # dh_installinit -r creates the necessary start action.
- invoke-rc.d dbus stop || true
+ # Do not restart dbus on upgrades, only on fresh installations.
+ # (dh_installinit -r creates a start action)
+ # But do reload it so the machine-id can be generated
+ if /etc/init.d/dbus status > /dev/null; then
+ # trigger an update notification which recommends to reboot
+ [ -x /usr/share/update-notifier/notify-reboot-required ] && \
+ /usr/share/update-notifier/notify-reboot-required || true
+ if [ -x "/etc/init.d/dbus" ]; then
+ if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
+ invoke-rc.d dbus reload || true
+ else
+ /etc/init.d/dbus reload || true
+ fi
+ fi
+ fi
fi
#DEBHELPER#