summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5995460f..181375c1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,13 +13,19 @@ VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Ver
export DH_VERBOSE=1
build:
-# Nothing to do.
+ # Run regression tests.
+ $(MAKE) test
clean:
./dh_testdir
./dh_testroot
./dh_clean
+test:
+ ./dh_clean
+ perl -MTest::Harness -e 'runtests @ARGV' t/*
+ -rm -rf debian/tmp
+
# Build architecture-dependent files here.
binary-arch: build
# Nothing to do.