summaryrefslogtreecommitdiff
path: root/debian/samples/c/Makefile.debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/samples/c/Makefile.debian')
-rw-r--r--debian/samples/c/Makefile.debian15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/samples/c/Makefile.debian b/debian/samples/c/Makefile.debian
new file mode 100644
index 0000000..66afb33
--- /dev/null
+++ b/debian/samples/c/Makefile.debian
@@ -0,0 +1,15 @@
+all: contours convert_cascade delaunay fback_c morphology motempl \
+ polar_transforms pyramid_segmentation adaptiveskindetector \
+ bgfg_codebook blobtrack_sample facedetect find_obj_calonder \
+ find_obj find_obj_ferns latentsvmdetect mser_sample mushroom \
+ one_way_sample tree_engine example_cmake/minarea
+
+example_cmake/minarea: example_cmake/minarea.c
+
+CPPFLAGS += $(shell pkg-config opencv --cflags)
+LOADLIBES += $(shell pkg-config opencv --libs)
+LOADLIBES += -lm
+CFLAGS += -Wall
+CXXFLAGS += -Wall
+CFLAGS += -O2
+CXXFLAGS += -O2