summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2013-11-21 06:20:01 +0100
committerGuillem Jover <guillem@debian.org>2013-12-05 10:19:33 +0100
commit80cc83904a4cc04f1b7a4ebe0439fea25bbaaf74 (patch)
treeee1abb5c5b24fed494cbc1473af37e67e5c82322 /configure.ac
parentcf21cccb98bdb31a84bbe1aa1217c712b47aedd2 (diff)
downloaddpkg-80cc83904a4cc04f1b7a4ebe0439fea25bbaaf74.tar.gz
dselect: Use C++11 nullptr instead of 0 or NULL
It is way more descriptive, and has a better type. Check for C++11 compiler support and fallback nullptr to 0 if unavailable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e3c6607bb..33f990ba3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,7 @@ DPKG_DEB_COMPRESSOR([xz])
AC_PROG_CC
DPKG_C_C99
AC_PROG_CXX
+DPKG_CXX_CXX11
AC_PROG_LEX
DPKG_DIST_CHECK([test "$LEX" = ":"], [lex program required])
AC_PROG_RANLIB