Age | Commit message (Collapse) | Author | Files | Lines | |
---|---|---|---|---|---|
2010-11-19 | libdpkg: Rename informative to pkg_is_informative | Guillem Jover | 1 | -2/+2 | |
2010-11-19 | libdpkg: Rename illegal_packagename to pkg_name_is_illegal | Guillem Jover | 3 | -3/+3 | |
2010-11-19 | libdpkg: Rename illegal_triggername to trig_name_is_illegal | Guillem Jover | 1 | -1/+2 | |
2010-11-19 | dpkg-trigger: Remove duplicate command name from error messages | Guillem Jover | 1 | -3/+3 | |
2010-11-19 | libdpkg: Namespace package database functions with pkg_db_ prefix | Guillem Jover | 12 | -47/+47 | |
2010-11-19 | libdpkg: Use push_error_context_jump() instead of push_error_handler() | Guillem Jover | 3 | -3/+6 | |
Remove obsolete and now unused push_error_handler compatibility macro. | |||||
2010-11-19 | libdpkg: Rename error_unwind() to pop_error_context() | Guillem Jover | 4 | -7/+8 | |
2010-11-19 | Use push_error_context() instead of ad-hoc code | Guillem Jover | 5 | -16/+7 | |
2010-11-19 | Move error context display handler reset to error_unwind() | Guillem Jover | 4 | -4/+3 | |
Never print an error message when doing normal cleanup, as this is something we always want to do. | |||||
2010-11-19 | dpkg-query: Fix --search not found string to be more meaningful | Guillem Jover | 1 | -1/+2 | |
2010-11-19 | Use thisname variable instead of hard-coded 'dpkg' string | Guillem Jover | 3 | -5/+7 | |
This corrects the current program name printed by other tools. | |||||
2010-11-19 | dpkg-divert: Use DPKG_MAINTSCRIPT_PACKAGE environment variable | Guillem Jover | 1 | -0/+5 | |
Use it as package name on when no --package or --local options have been specified. | |||||
2010-11-19 | Use setaction() instead of directly assigning to cipaction | Guillem Jover | 2 | -2/+2 | |
2010-11-19 | libdpkg: Rename print_error_fatal() to print_fatal_error() | Guillem Jover | 1 | -1/+1 | |
2010-11-19 | libdpkg: Refactor default error handler into new catch_fatal_error() | Guillem Jover | 1 | -1/+1 | |
2010-11-19 | Add a comment for translators to 'dpkg-query -l' header string | Guillem Jover | 1 | -0/+6 | |
Reported-by: Ask Hjorth Larsen <asklarsen@gmail.com> | |||||
2010-11-19 | Do not make function typedefs pointers | Guillem Jover | 1 | -1/+1 | |
2010-11-19 | libdpkg: Rename voidfnp to void_func | Guillem Jover | 1 | -1/+1 | |
2010-11-19 | Move action and obsolete related functionality to the myopt module | Guillem Jover | 5 | -65/+0 | |
Reduce repeated code, and localize it where it belongs. | |||||
2010-11-19 | Refactor file_stat code | Guillem Jover | 4 | -56/+50 | |
Create a new file_stat struct, and use it instead of the filestatoverride one. | |||||
2010-11-02 | Unify execution error strings | Guillem Jover | 3 | -9/+15 | |
2010-11-02 | dpkg: Rename unlinkorrmdir() to secure_remove() | Guillem Jover | 3 | -8/+12 | |
Maps better to the system remove(2) function name. | |||||
2010-09-19 | Merge commit '1.15.8.5' | Raphaël Hertzog | 4 | -7/+15 | |
2010-08-26 | Add gettext messages for plural forms | Guillem Jover | 4 | -7/+15 | |
Some of the singular forms are not currently used, but we keep them for consistency, and to avoid confusing translators. Closes: #594218 | |||||
2010-08-13 | Merge branch 'sid' (through tag '1.15.8.4') | Guillem Jover | 4 | -4/+9 | |
Conflicts: debian/changelog scripts/po/de.po | |||||
2010-08-13 | Remove spurious leftover .dpkg-tmp files after unpacking failure | Sven Joachim | 1 | -0/+4 | |
Renaming the backup copy to the old name is a no-op if these are hard links to the same file. So we need to remove the backup copy afterwards to make sure it is gone. Closes: #591993 Signed-off-by: Guillem Jover <guillem@debian.org> | |||||
2010-08-13 | dpkg-statoverride: Fix typos | Guillem Jover | 2 | -3/+3 | |
2010-08-13 | libdpkg: When parsing database files only warn on bogus versions | Guillem Jover | 1 | -1/+2 | |
Those versions, although bogus, were previously accepted, so to avoid breaking systems by making dpkg refuse to parse the status and available files, we just make it warn for now, and will make it error out on status file parsing later on. We keep producing errors on the rest of version parsing to avoid newly introduced bogosity and so that packages get fixed, while not making the system unusable anymore. Closes: #590885, #590896, #591692, #591885 | |||||
2010-08-03 | Move glob module to libdpkg | Guillem Jover | 5 | -93/+2 | |
2010-08-01 | Fix dpkg-divert test suite to cope with + in the build directory name | Jonathan Nieder | 1 | -5/+5 | |
The directory name was not properly escaped in regular expressions and lead to test failures when it contained + or other characters with special meanings in regular expressions. Signed-off-by: Raphaël Hertzog <hertzog@debian.org> | |||||
2010-07-29 | dpkg: Assign correct SE Linux label to non-regular files | Guillem Jover | 1 | -4/+6 | |
The call to matchpathcon() was getting passed only the permission bits of the mode argument, instead of the format type. Map the tar filetype to the Unix mode and OR that information into the tar_entry mode member. Closes: #587949 Based-on-patch-by: Russell Coker <russell@coker.com.au> Signed-off-by: Guillem Jover <guillem@debian.org> | |||||
2010-07-29 | libdpkg: Rename TarInfo to tar_entry | Guillem Jover | 4 | -9/+14 | |
2010-07-29 | libdpkg: Rename TarExtractor to tar_extractor | Guillem Jover | 2 | -2/+2 | |
2010-07-29 | libdpkg: Rename and lower-case TarInfo members | Guillem Jover | 2 | -70/+80 | |
2010-07-29 | libdpkg: Normalize tar_filetype_file0 to tar_filetype_file on decode | Guillem Jover | 1 | -5/+2 | |
2010-07-29 | libdpkg: Rename and namespace TarFileType to tar_filetype | Guillem Jover | 2 | -26/+31 | |
2010-07-29 | Pass tar context pointer as an argument instead of a struct member | Guillem Jover | 2 | -11/+10 | |
The context does not have anything to do with the TarInfo struct, so pass it as a function argument either as 'void *' or as 'struct tarcontext *' if the type is known. | |||||
2010-07-26 | Use varbuf_trunc instead of directly assigning to member 'used' | Guillem Jover | 5 | -18/+22 | |
2010-07-25 | build: Fix “make distcheck” errors | Sven Joachim | 1 | -0/+3 | |
Ship the doc/lcov-{epi,pro}log files created in commit 0581dda824f26e9eec996ebf4de5f6474336bec2 in the distribution tarball, as well as the dpkg-divert test that moved in commit 577ab5dd513beb641f1d635d8ead681065254233. | |||||
2010-07-22 | Check the stat structure only if it has been initialized | Raphaël Hertzog | 1 | -1/+2 | |
For non-existing files the stat structure is not initialized and S_ISDIR would randomly return true leading to the "Cannot divert directories" error message. This fixes the test-suite on i386. | |||||
2010-07-21 | dpkg: Stop exporting DPKG_LIBDIR to maintainer scripts | Guillem Jover | 2 | -2/+0 | |
Now that the maintainer scripts helper program is under PATH, there's no need anymore to export the internal dpkg library directory. | |||||
2010-07-21 | Do not include two unused <assert.h> | Guillem Jover | 1 | -1/+0 | |
2010-07-16 | dpkg-query: Rename query.c to querycmd.c | Guillem Jover | 2 | -2/+2 | |
This makes it obvious the file contains the main() function for dpkg-query in line with the rest of the tools. | |||||
2010-07-16 | Fix file names in comment header | Guillem Jover | 1 | -1/+1 | |
2010-07-16 | dpkg-query: Do not incorrectly trim package summary on --list | Guillem Jover | 1 | -1/+1 | |
When computing the longest package description, the code was using always the first package passed to list1package. Which made it trim to an incorrect size. | |||||
2010-07-16 | dpkg-query: Use pkg_summary in list1package instead of ad-hoc code | Guillem Jover | 1 | -5/+2 | |
2010-07-16 | libdpkg: Make pkg_summary() return the summary instead of void | Guillem Jover | 2 | -2/+2 | |
Change from returning through a pointer argument to returning it from the function return value. | |||||
2010-07-16 | Move pkg-show module to libdpkg | Guillem Jover | 5 | -54/+2 | |
2010-07-16 | Convert limiteddescription() to pkg_summary() | Guillem Jover | 4 | -11/+16 | |
Move clamping of summary size to callers. This makes the function more generic so that it can be reused in other contexts. | |||||
2010-07-16 | Switch variables from int to bool where appropriate | Guillem Jover | 3 | -14/+17 | |