summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-25 16:44:37 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-25 16:44:37 +0300
commit4927b084a932e2445e9626e2e4e5a558aee59518 (patch)
treee8bb9406e1964639328ffab1be254eee4a88e468 /debian/rules
downloadfakeroot-4927b084a932e2445e9626e2e4e5a558aee59518.tar.gz
Import fakeroot (1.24-1)debian/1.24-1debian
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules69
1 files changed, 69 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7f1bf74
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,69 @@
+#!/usr/bin/make -f
+
+export DH_VERBOSE = 1
+
+include /usr/share/dpkg/architecture.mk
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
+endif
+
+LIB_DIR = usr/lib/$(DEB_HOST_MULTIARCH)
+
+%:
+ dh $@
+
+dhar-stamp:
+ dh_autoreconf
+ (cd doc && po4a -k 0 --rm-backups --variable "srcdir=../doc/" po4a/po4a.cfg) || exit 1
+ touch $@
+
+obj-sysv/config.status: dhar-stamp
+ dh_testdir
+ mkdir obj-sysv
+ cd obj-sysv && CFLAGS="$(CFLAGS)" ../configure --prefix=/usr --mandir=/usr/share/man --libdir=/$(LIB_DIR)/libfakeroot --program-suffix=-sysv $(CONFARGS)
+
+obj-tcp/config.status: dhar-stamp
+ dh_testdir
+ mkdir obj-tcp
+ cd obj-tcp && CFLAGS="$(CFLAGS)" ../configure --prefix=/usr --mandir=/usr/share/man --libdir=/$(LIB_DIR)/libfakeroot --with-ipc=tcp --program-suffix=-tcp $(CONFARGS)
+
+override_dh_auto_configure: obj-sysv/config.status obj-tcp/config.status
+
+override_dh_auto_build:
+ cd obj-sysv && $(MAKE)
+ cd obj-tcp && $(MAKE)
+ifneq ($(DEB_HOST_GNU_SYSTEM),gnu)
+ sed 's/@FAKEROOT_SYSV_ALTPRIO@/50/;s/@FAKEROOT_TCP_ALTPRIO@/30/;' \
+ debian/fakeroot.postinst.in > debian/fakeroot.postinst
+else
+ sed 's/@FAKEROOT_SYSV_ALTPRIO@/30/;s/@FAKEROOT_TCP_ALTPRIO@/50/;' \
+ debian/fakeroot.postinst.in > debian/fakeroot.postinst
+endif
+ sed 's,@LIBDIR@,/$(LIB_DIR),g' \
+ debian/libfakeroot.links.in > debian/libfakeroot.links
+
+override_dh_auto_test:
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ifeq (,$(findstring hurd, $(DEB_HOST_ARCH_OS)))
+ cd obj-sysv && $(MAKE) check
+endif
+ cd obj-tcp && $(MAKE) check
+endif
+endif
+
+override_dh_auto_install:
+ cd obj-tcp && $(MAKE) DESTDIR="$(CURDIR)/debian/tmp" install
+ mv debian/tmp/$(LIB_DIR)/libfakeroot/libfakeroot-0.so debian/tmp/$(LIB_DIR)/libfakeroot/libfakeroot-tcp.so
+ cd obj-sysv && $(MAKE) DESTDIR="$(CURDIR)/debian/tmp" install
+ mv debian/tmp/$(LIB_DIR)/libfakeroot/libfakeroot-0.so debian/tmp/$(LIB_DIR)/libfakeroot/libfakeroot-sysv.so
+ mkdir -p debian/tmp/etc/ld.so.conf.d
+ echo /$(LIB_DIR)/libfakeroot > debian/tmp/etc/ld.so.conf.d/fakeroot-$(DEB_HOST_MULTIARCH).conf
+
+override_dh_auto_clean:
+ rm -rf obj-sysv obj-tcp
+ dh_autoreconf_clean
+ rm -f dhar-stamp
+ $(RM) debian/fakeroot.postinst
+ $(RM) debian/libfakeroot.links