summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/rules.d/binary-cxx.mk6
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b800852..7f07759 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ gcc-4.8 (4.8.3-5) UNRELEASED; urgency=medium
* Update to SVN 20140717 (r212756) from the gcc-4_8-branch.
* Warn about ppc ELFv2 ABI issues, which will change in GCC 4.10.
+ * Fix installing test logs and summaries.
-- Matthias Klose <doko@debian.org> Thu, 17 Jul 2014 16:12:10 +0200
diff --git a/debian/rules.d/binary-cxx.mk b/debian/rules.d/binary-cxx.mk
index 8ce3e0a..5574e67 100644
--- a/debian/rules.d/binary-cxx.mk
+++ b/debian/rules.d/binary-cxx.mk
@@ -61,7 +61,8 @@ endif
echo "TEST COMPARE BEGIN"
ifeq ($(with_check),yes)
# more than one libgo.sum, avoid it
- cp -p $$(find $(builddir) -mindepth 3 -name '*.sum' ! -name libgo.sum) \
+ cp -p $$(find $(builddir)/gcc/testsuite -maxdepth 2 \( -name '*.sum' -o -name '*.log' \)) \
+ $$(find $(buildlibdir)/*/testsuite -maxdepth 1 \( -name '*.sum' -o -name '*.log' \) ! -name 'libgo.*') \
$(d_cxx)/$(docdir)/$(p_xbase)/test-summaries/
ifeq ($(with_go),yes)
cp -p $(buildlibdir)/libgo/libgo.sum \
@@ -84,6 +85,9 @@ ifeq ($(with_check),yes)
fi; \
done
endif
+ if which xz 2>&1 >/dev/null; then \
+ xz -9v $(d_cxx)/$(docdir)/$(p_xbase)/test-summaries/*
+ fi
else
echo "Nothing to compare (testsuite not run)"
endif