summaryrefslogtreecommitdiff
path: root/debian/rules.d
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d')
-rw-r--r--debian/rules.d/binary-go.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules.d/binary-go.mk b/debian/rules.d/binary-go.mk
index 8b484df..88d767c 100644
--- a/debian/rules.d/binary-go.mk
+++ b/debian/rules.d/binary-go.mk
@@ -42,10 +42,15 @@ dirs_go = \
$(PF)/include \
$(PF)/share/man/man1
files_go = \
- $(PF)/bin/$(cmd_prefix){gccgo,go,gofmt}$(pkg_ver) \
+ $(PF)/bin/$(cmd_prefix)gccgo$(pkg_ver) \
$(gcc_lexec_dir)/{cgo,go1} \
$(PF)/share/man/man1/{go,gofmt}$(pkg_ver).1
+ifneq (,$(filter $(build_type), build-native cross-build-native))
+ files_go += \
+ $(PF)/bin/{go,gofmt}$(pkg_ver)
+endif
+
ifneq ($(GFDL_INVARIANT_FREE),yes)
files_go += \
$(PF)/share/man/man1/$(cmd_prefix)gccgo$(pkg_ver).1