summaryrefslogtreecommitdiff
path: root/debian/rules.defs
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.defs')
-rw-r--r--debian/rules.defs10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules.defs b/debian/rules.defs
index cb2ce42..ed0493a 100644
--- a/debian/rules.defs
+++ b/debian/rules.defs
@@ -560,7 +560,12 @@ ada_no_cpus += x32 # see https://gcc.gnu.org/PR61954
ifneq (,$(filter $(distrelease),trusty))
ada_no_cpus += arm64
endif
-ada_no_systems :=
+# FUCKED UP:
+# this disables build dependnecies for illumos-amd64,
+# but this is used to be GNU triplet.
+# Thank you. Fuck you.
+ada_no_systems := illumos-amd64
+
ada_no_cross := no
ada_no_snap := no
ifeq ($(single_package),yes)
@@ -599,6 +604,9 @@ endif
ifneq (,$(filter $(distrelease),lucid))
with_ada :=
endif
+ifeq ($(DEB_BUILD_ARCH),illumos-amd64)
+ with_ada := no gnat on Dyson yet
+endif
with_ada := $(call envfilt, ada, , , $(with_ada))