summaryrefslogtreecommitdiff
path: root/debian/rules.d/binary-cxx.mk
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-18 15:53:29 +0300
commit8f6c4b0033c72f8ac14694c419a99458339dd6a9 (patch)
tree06c106e622a58100aa85a381b9b65d222b076df4 /debian/rules.d/binary-cxx.mk
parent42156b5190f4fa150e1fab6777eb81e69d4db8c9 (diff)
downloadgcc-9-8f6c4b0033c72f8ac14694c419a99458339dd6a9.tar.gz
Import gcc-9 (9.2.1-19)debian/9.2.1-19debian
Diffstat (limited to 'debian/rules.d/binary-cxx.mk')
-rw-r--r--debian/rules.d/binary-cxx.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules.d/binary-cxx.mk b/debian/rules.d/binary-cxx.mk
index 17a43c0..aaa3235 100644
--- a/debian/rules.d/binary-cxx.mk
+++ b/debian/rules.d/binary-cxx.mk
@@ -42,8 +42,10 @@ ifeq ($(unprefixed_names),yes)
endif
endif
-ifeq ($(GFDL_INVARIANT_FREE),yes)
mkdir -p $(d_cxx)/usr/share/lintian/overrides
+ echo '$(p_cxx) binary: hardening-no-pie' \
+ > $(d_cxx)/usr/share/lintian/overrides/$(p_cxx)
+ifeq ($(GFDL_INVARIANT_FREE),yes)
echo '$(p_cxx) binary: binary-without-manpage' \
>> $(d_cxx)/usr/share/lintian/overrides/$(p_cxx)
endif
@@ -55,6 +57,10 @@ endif
debian/dh_rmemptydirs -p$(p_cxx)
dh_shlibdeps -p$(p_cxx)
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTONS)))
+ $(DWZ) \
+ $(d_cxx)/$(gcc_lexec_dir)/cc1plus
+endif
dh_strip -p$(p_cxx) $(if $(unstripped_exe),-X/cc1plus)
echo $(p_cxx) >> debian/arch_binaries