summaryrefslogtreecommitdiff
path: root/debian/patches/ada-arm.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/ada-arm.diff')
-rw-r--r--debian/patches/ada-arm.diff18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/patches/ada-arm.diff b/debian/patches/ada-arm.diff
new file mode 100644
index 0000000..ce7f9bc
--- /dev/null
+++ b/debian/patches/ada-arm.diff
@@ -0,0 +1,18 @@
+DP: Improve support for ZCX on arm.
+
+Index: b/src/gcc/ada/gcc-interface/Makefile.in
+===================================================================
+--- a/src/gcc/ada/gcc-interface/Makefile.in
++++ b/src/gcc/ada/gcc-interface/Makefile.in
+@@ -1964,7 +1964,10 @@ ifeq ($(strip $(filter-out arm% linux-gn
+ LIBGNAT_TARGET_PAIRS += \
+ system.ads<system-linux-armeb.ads
+ else
+- EH_MECHANISM=-arm
++ # Special case; the GCC exception mechanism is supported under
++ # another name and with different files than for other
++ # target_cpus.
++ override EH_MECHANISM=-arm
+ LIBGNAT_TARGET_PAIRS += \
+ system.ads<system-linux-armel.ads \
+ a-exexpr.adb<a-exexpr-gcc.adb \