summaryrefslogtreecommitdiff
path: root/debian/patches/gotools-configury.diff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/gotools-configury.diff')
-rw-r--r--debian/patches/gotools-configury.diff19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/patches/gotools-configury.diff b/debian/patches/gotools-configury.diff
new file mode 100644
index 0000000..6054709
--- /dev/null
+++ b/debian/patches/gotools-configury.diff
@@ -0,0 +1,19 @@
+# DP: Fix gotools cross build.
+
+ * Makefile.am: Use GOC configured in configure.ac for cross builds.
+ * configure.ac: Fix NATIVE conditional.
+ * Makefile.in, configure: Regenerate.
+
+Index: b/src/gotools/configure.ac
+===================================================================
+--- a/src/gotools/configure.ac
++++ b/src/gotools/configure.ac
+@@ -46,7 +46,7 @@ AC_PROG_INSTALL
+ AC_PROG_CC
+ AC_PROG_GO
+
+-AM_CONDITIONAL(NATIVE, test "$cross_compiling" = no)
++AM_CONDITIONAL(NATIVE, test "$host" = "$target")
+
+ dnl Test for -lsocket and -lnsl. Copied from libjava/configure.ac.
+ AC_CACHE_CHECK([for socket libraries], gotools_cv_lib_sockets,