summaryrefslogtreecommitdiff
path: root/debian/rules.d/binary-libgcc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.d/binary-libgcc.mk')
-rw-r--r--debian/rules.d/binary-libgcc.mk39
1 files changed, 22 insertions, 17 deletions
diff --git a/debian/rules.d/binary-libgcc.mk b/debian/rules.d/binary-libgcc.mk
index 4b2ef1f..3020aa2 100644
--- a/debian/rules.d/binary-libgcc.mk
+++ b/debian/rules.d/binary-libgcc.mk
@@ -47,17 +47,22 @@ endif
header_files = \
$(gcc_lib_dir)/include/std*.h \
$(shell for h in \
- README features.h arm_fp16.h arm_neon.h loongson.h \
- {cpuid,decfloat,float,iso646,limits,mm3dnow,mm_malloc}.h \
+ README features.h arm_fp16.h arm_neon.h arm_cmse.h loongson.h \
+ {cpuid,decfloat,float,gcov,iso646,limits,mm3dnow,mm_malloc}.h \
{ppu_intrinsics,paired,spu2vmx,vec_types,si2vmx}.h \
{,a,b,e,i,n,p,s,t,w,x}mmintrin.h mmintrin-common.h \
{abm,adx,avx,avx2,bmi,bmi2,f16c,fma,fma4,fxsr,ia32,}intrin.h \
{lwp,lzcnt,popcnt,prfchw,rdseed,rtm,tbm,x86,xop,xsave{,opt},xtest,}intrin.h \
- {htm,htmxl,mwaitx,pku,sha,vec}intrin.h \
+ {htm,htmxl,mwaitx,pku,sha,vaes,vec,sgx}intrin.h \
avx512{bw,er,cd,dq,f,ifma,ifmavl,pf,vlbw,vbmi,vldq,vbmivl,vl}intrin.h \
- {clflushopt,clwb,clzero,pcommit,xsavec,xsaves}intrin.h \
+ avx512{4fmaps,4vnniw,bitalg,vnni,vnnivl,vpopcntdq,vpopcntdqvl}intrin.h \
+ avx512vbmi{2,2vl}intrin.h \
+ {movdir,pconfig,vpclmulqdq,wbnoinvd}intrin.h \
+ {cet,clflushopt,clwb,clzero,gfni,pcommit,xsavec,xsaves}intrin.h \
{arm_acle,unwind-arm-common,s390intrin}.h \
- {cross-stdarg,syslimits,unwind,varargs}.h; \
+ {cldemote,waitpkg}intrin.h \
+ amo.h msa.h \
+ {cet,cross-stdarg,syslimits,unwind,varargs}.h; \
do \
test -e $(d)/$(gcc_lib_dir)/include/$$h \
&& echo $(gcc_lib_dir)/include/$$h; \
@@ -92,8 +97,12 @@ ifeq ($(DEB_TARGET_ARCH),m68k)
header_files += $(gcc_lib_dir)/include/math-68881.h
endif
-ifeq ($(DEB_TARGET_ARCH),$(findstring $(DEB_TARGET_ARCH),powerpc ppc64 ppc64el powerpcspe))
- header_files += $(gcc_lib_dir)/include/{altivec.h,ppc-asm.h,spe.h}
+ifneq (,$(filter $(DEB_TARGET_ARCH),powerpc ppc64 ppc64el))
+ header_files += $(gcc_lib_dir)/include/{altivec.h,ppc-asm.h}
+endif
+
+ifeq ($(DEB_TARGET_ARCH),powerpcspe)
+ header_files += $(gcc_lib_dir)/include/{ppc-asm.h,spe.h}
endif
ifeq ($(DEB_TARGET_ARCH),tilegx)
@@ -243,6 +252,7 @@ define __do_gcc_devels2
)
$(if $(1),,$(if $(filter yes, $(with_lsan)),
$(call install_gcc_lib,liblsan,$(LSAN_SONAME),$(1),$(2))
+ mv $(4)/liblsan_preinit.o debian/$(2)/$(3)/;
))
$(if $(1),,$(if $(filter yes, $(with_tsan)),
$(call install_gcc_lib,libtsan,$(TSAN_SONAME),$(1),$(2))
@@ -256,12 +266,6 @@ define __do_gcc_devels2
$(if $(filter yes, $(with_cilkrts)),
$(call install_gcc_lib,libcilkrts,$(CILKRTS_SONAME),$(1),$(2))
)
- $(if $(filter yes, $(with_mpx)),
- $(if $(filter x32, $(1)),,
- $(call install_gcc_lib,libmpxwrappers,$(MPX_SONAME),$(1),$(2))
- $(call install_gcc_lib,libmpx,$(MPX_SONAME),$(1),$(2))
- )
- )
$(if $(filter yes, $(with_qmath)),
$(call install_gcc_lib,libquadmath,$(QUADMATH_SONAME),$(1),$(2))
)
@@ -289,6 +293,11 @@ define __do_libgcc
$(d_l)/$(libgcc_dir$(2))/.
)
+ $(if $(filter yes, $(with_internal_libunwind)),
+ mv $(d)/$(usr_lib$(2))/libunwind.* \
+ $(d_l)/$(libgcc_dir$(2))/.
+ )
+
debian/dh_doclink -p$(p_l) $(if $(3),$(3),$(p_lbase))
debian/dh_doclink -p$(p_d) $(if $(3),$(3),$(p_lbase))
debian/dh_rmemptydirs -p$(p_l)
@@ -335,11 +344,7 @@ do_libgcc = $(call __do_libgcc,lib$(1)gcc$(GCC_SONAME),$(1),$(2))
# ----------------------------------------------------------------------
$(binary_stamp)-libgcc: $(install_dependencies)
-ifeq ($(with_standalone_gcj),yes)
- $(call do_libgcc,,$(p_jbase))
-else
$(call do_libgcc,,)
-endif
$(binary_stamp)-lib64gcc: $(install_dependencies)
$(call do_libgcc,64,)