summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 1108c0f..31585bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,7 @@
# version number of the defaults package
VDEF := $(strip $(shell dpkg-parsechangelog | awk -F: '/^Version:/ {print $$NF}'))
SOURCE := $(strip $(shell dpkg-parsechangelog | awk -F: '/^Source:/ {print $$NF}'))
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
VMAJOR := $(shell echo $(VDEF) | awk -F. '{print $$1}')
VMINOR := $(shell echo $(VDEF) | awk -F. '{print $$2}' | sed -e 's/\([0-9]*\).*/\1/')
@@ -303,10 +304,12 @@ lib32 = /usr/lib32
multilib_archs = $(sort \
amd64 i386 kfreebsd-amd64 mips64 mips64el mipsel \
powerpc ppc64 s390 s390x sparc sparc64 x32 \
+ illumos-amd64 \
$(if $(filter $(vendor), Ubuntu), armel armhf))
go_archs = alpha amd64 arm64 armel armhf i386 ia64 \
mips64 mipsel mips64el mipsn32 mipsn32el \
+ illumos-amd64 \
mipsr6 mipsr6el mipsn32r6 mipsn32r6el mips64r6 mips64r6el \
powerpc powerpcspe ppc64 ppc64el riscv64 s390 s390x sparc sparc64 x32
@@ -448,6 +451,9 @@ with_gfdl_docs := no
ifeq ($(distribution),Ubuntu)
with_gfdl_docs := yes
endif
+ifeq ($(DEB_HOST_ARCH_OS),illumos)
+ with_gfdl_docs := yes
+endif
ifeq ($(with_native),yes)
ifeq (,$(filter $(DEB_HOST_ARCH),$(go_archs)))
@@ -765,6 +771,11 @@ ifeq ($(with_native),yes)
dh_link -pcpp \
/usr/bin/cpp-$(PV_CPP) /usr/bin/cpp \
/usr/bin/cpp-$(PV_CPP) /usr/bin/$(DEB_HOST_GNU_TYPE)-cpp
+ ifeq (illumos,$(DEB_HOST_ARCH_OS))
+ # rpcgen uses /usr/lib/cpp by default:
+ dh_link -pcpp \
+ /usr/bin/cpp /usr/lib/cpp
+ endif
ifeq ($(with_gfdl_docs),yes)
for i in gfdl.7 gpl.7 fsf-funding.7; do \