summaryrefslogtreecommitdiff
path: root/libc/debian/rules
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2015-10-19 09:05:24 +0300
committerIgor Pashev <pashev.igor@gmail.com>2015-10-19 09:05:24 +0300
commitd4a338740c7c5cf3df8f58609440837e64c14241 (patch)
treedd7a2416983f17b4a2fe02027b681e4fb60607f8 /libc/debian/rules
parent49350b78e2171b2ab023239441e94af83c5024e1 (diff)
downloadillumos-packaging-d4a338740c7c5cf3df8f58609440837e64c14241.tar.gz
Build commands
Diffstat (limited to 'libc/debian/rules')
-rwxr-xr-xlibc/debian/rules28
1 files changed, 6 insertions, 22 deletions
diff --git a/libc/debian/rules b/libc/debian/rules
index f13b9a7..177a83b 100755
--- a/libc/debian/rules
+++ b/libc/debian/rules
@@ -155,8 +155,6 @@ libsocket \
libnsl \
libgen \
-libc-mapfile := usr/src/lib/libc/port/mapfile-vers
-
override_dh_strip:
: # we don't strip *this* libc
@@ -203,40 +201,26 @@ override_dh_auto_build:
ln -svf $$ROOT/$$DEB_LIBDIR_64/liblddbg.so.4 \
$$ROOT/$$DEB_USRLIBDIR_64/liblddbg.so
+ # install headers
dh_illumos_make $(make) $(BUILD)/usr/src/head -t install_h
dh_illumos_make $(make) $(libs_headers:%=$(BUILD)/usr/src/lib/%) -t install_h
cp -vf $(BUILD)/usr/src/uts/common/sys/avl*.h $(ROOT)/usr/include/sys/
cp -vrf debian/compat_headers/* $(ROOT)/usr/include/
+ # build libs
dh_illumos_make $(libs:%=$(BUILD)/usr/src/lib/%)
dh_illumos_make $(nsswitch:%=$(BUILD)/usr/src/lib/nsswitch/%)
+
+ # build sgs
dh_illumos_make --native $(BUILD)/usr/src/cmd/sgs/tools
dh_illumos_make $(sgs:%=$(BUILD)/usr/src/cmd/sgs/%)
-
# these two are patched:
dh_illumos_make --native \
$(BUILD)/usr/src/cmd/sgs/ld/i386 \
$(BUILD)/usr/src/cmd/sgs/ldd/i386 \
-nsswitch-stamp: lib-stamp
- dh_illumos_make $(make) $(nsswitch:%=usr/src/lib/nsswitch/%)
- touch $@
-
-# Some libs and, more important, runtime linker are in usr/src/cmd/sgs.
-# We will not build all sgs stuff, but only related to libc.
-sgs-stamp: lib-stamp
- dh_illumos_make $(make) --native usr/src/cmd/sgs/tools
- dh_illumos_make $(make) $(sgs:%=usr/src/cmd/sgs/%)
- # We have patched this:
- dh_illumos_make $(make) --native \
- usr/src/cmd/sgs/ldd/i386 \
- usr/src/cmd/sgs/ld/i386 \
-
- touch $@
-
-cmd-stamp: lib-stamp sgs-stamp
- dh_illumos_make --native $(make) $(cmd:%=usr/src/cmd/%)
- touch $@
+ # build tools:
+ dh_illumos_make --native $(make) $(cmd:%=$(BUILD)/usr/src/cmd/%)
install-stamp: build-stamp
for l in `find debian/tmp/lib32 -maxdepth 1 -type l -name \*.so`; do \