summaryrefslogtreecommitdiff
path: root/onbld/debian
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2012-07-04 17:44:57 +0000
committerIgor Pashev <pashev.igor@gmail.com>2012-07-04 17:44:57 +0000
commita36a8684726499c772fddfa425a14e3db8e27f5d (patch)
tree925f5c1778b26e8734fa046d6041c4d16bc3d70d /onbld/debian
parentca7848a488fca80fb5ffa3f33ad1a014d23a901e (diff)
downloadillumos-packaging-a36a8684726499c772fddfa425a14e3db8e27f5d.tar.gz
Install in debian/tmp
Diffstat (limited to 'onbld/debian')
-rwxr-xr-xonbld/debian/rules12
1 files changed, 8 insertions, 4 deletions
diff --git a/onbld/debian/rules b/onbld/debian/rules
index d95d71b..bc37482 100755
--- a/onbld/debian/rules
+++ b/onbld/debian/rules
@@ -9,12 +9,16 @@ unpack-stamp:
--exclude=usr/src/cmd \
--exclude=usr/src/man \
--exclude=usr/src/head
- # i386_XARCH is set to -m32 by dh_illumos_gate, but
- # we want native arch (64-bit):
- echo "export i386_XARCH=''" >> illumos-gate/env.sh
+ # i386_XARCH is set to -m32 by dh_illumos_gate,
+ # but we want native arch (64-bit):
+ sed -i -r "s/.*(export i386_XARCH=).*/\1/" illumos-gate/env.sh
# libncurses.so is actually linker script
- # and sunld does not understand it, but we do not need sunld here ;-)
+ # and sunld does not understand it,
+ # but we do not need sunld here ;-)
sed -i /LD_ALTEXEC/d illumos-gate/env.sh
+ # install into debian/tmp:
+ echo 'export TOOLS_PROTO="$$ROOT"' >> illumos-gate/env.sh
+ sed -i '/^TOOLS_PROTO=/d' illumos-gate/bldenv.sh
touch $@
patch: unpack