summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..fcc2fbe
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,30 @@
+ACLOCAL_AMFLAGS = -I m4
+
+lib_LTLIBRARIES = libsunavl.la
+
+libsunavl_la_SOURCES = \
+usr/src/common/avl/avl.c \
+usr/src/uts/common/sys/avl.h \
+usr/src/uts/common/sys/avl_impl.h
+
+# VERSION_SCRIPT is defined in linker supports
+# symbol versioning and versioning is enabled.
+# Otherwise VERSION_SCRIPT is empty.
+
+libsunavl_la_LDFLAGS = -version-info 2:0:0
+if USE_VERSION_SCRIPT
+libsunavl_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)$(top_srcdir)/libsunavl.vers
+endif
+
+AM_CPPFLAGS = \
+-I$(top_srcdir)/usr/src/uts/common/sys \
+$(CPPFLAGS_DEBUG)
+
+libsunavldir = $(includedir)/libsunavl
+libsunavl_HEADERS = \
+usr/src/uts/common/sys/avl.h \
+usr/src/uts/common/sys/avl_impl.h
+
+include_HEADERS = libsunavl.h
+
+EXTRA_DIST = libsunavl.vers LICENSE