summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndřej Surý <ondrej@sury.org>2013-06-26 14:40:52 +0200
committerOndřej Surý <ondrej@sury.org>2013-06-26 14:40:52 +0200
commit0cac4b045de75e9220d54ea0c2348655c2d433c2 (patch)
treeee851b6f2212c5b680b12d7f5c57840630f63bac
parent509ad7fe247fea6f5a60f231b3496fb4d8bc778b (diff)
downloadknot-0cac4b045de75e9220d54ea0c2348655c2d433c2.tar.gz
Install minimal example configuration file as /etc/knot/knot.conf
-rw-r--r--debian/knot.examples1
-rw-r--r--debian/knot.install1
-rw-r--r--debian/patches/run-as-knot.knot.patch26
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
5 files changed, 30 insertions, 1 deletions
diff --git a/debian/knot.examples b/debian/knot.examples
deleted file mode 100644
index 44477f4..0000000
--- a/debian/knot.examples
+++ /dev/null
@@ -1 +0,0 @@
-debian/tmp/etc/knot/*
diff --git a/debian/knot.install b/debian/knot.install
index 2e926ca..b0bf0d8 100644
--- a/debian/knot.install
+++ b/debian/knot.install
@@ -4,3 +4,4 @@ usr/sbin/knotd
usr/share/man/man5
usr/share/man/man8
usr/share/info
+etc/knot/knot.conf
diff --git a/debian/patches/run-as-knot.knot.patch b/debian/patches/run-as-knot.knot.patch
new file mode 100644
index 0000000..cfc42bb
--- /dev/null
+++ b/debian/patches/run-as-knot.knot.patch
@@ -0,0 +1,26 @@
+--- knot.orig/samples/knot.sample.conf.in
++++ knot/samples/knot.sample.conf.in
+@@ -1,16 +1,19 @@
+ system {
+ identity "@package@ @version@";
+ storage "@localstatedir@/@package@";
++ user knot.knot;
++ pidfile "/run/knot/knotd.pid";
+ }
+
+ interfaces {
+- my-iface { address 127.0.0.1@5353; }
++ v4-interface { address 127.0.0.1@53; }
++ # v6-interface { address ::1@53; }
+ }
+
+ zones {
+- example.com {
+- file "@sysconfdir@/example.com.zone";
+- }
++# example.com {
++# file "@sysconfdir@/example.com.zone";
++# }
+ }
+
+ log {
diff --git a/debian/patches/series b/debian/patches/series
index 03d2e79..c5e1303 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
0001-move_pidfile_to_var_run.patch
knotd-pidfile.patch
+run-as-knot.knot.patch
diff --git a/debian/rules b/debian/rules
index 5554a95..262736b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -23,4 +23,6 @@ override_dh_strip:
dh_strip --dbg-package=knot-dbg
override_dh_install:
+ mv $(CURDIR)/debian/tmp/etc/knot/knot.sample.conf $(CURDIR)/debian/tmp/knot/knot.conf
+ rm $(CURDIR)/debian/tmp/etc/knot/example.com.zone
dh_install --list-missing