summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/0001-move_pidfile_to_var_run.patch4
-rw-r--r--debian/patches/0002-get_rid_of_AM_MAINTAINER_MODE.patch12
-rw-r--r--debian/patches/0003-fix_manpage_section.patch13
-rw-r--r--debian/patches/series2
4 files changed, 2 insertions, 29 deletions
diff --git a/debian/patches/0001-move_pidfile_to_var_run.patch b/debian/patches/0001-move_pidfile_to_var_run.patch
index 68142e6..511631c 100644
--- a/debian/patches/0001-move_pidfile_to_var_run.patch
+++ b/debian/patches/0001-move_pidfile_to_var_run.patch
@@ -11,12 +11,12 @@
* Server.
--- a/src/knot/conf/conf.c
+++ b/src/knot/conf/conf.c
-@@ -130,7 +130,7 @@ static int conf_process(conf_t *conf)
+@@ -129,7 +129,7 @@ static int conf_process(conf_t *conf)
// Create PID file
if (conf->pidfile == NULL) {
- conf->pidfile = strcdup(conf->storage, "/" PID_FILE);
+ conf->pidfile = strdup(PID_FILE);
if (conf->pidfile == NULL) {
- return KNOTD_ENOMEM;
+ return KNOT_ENOMEM;
}
diff --git a/debian/patches/0002-get_rid_of_AM_MAINTAINER_MODE.patch b/debian/patches/0002-get_rid_of_AM_MAINTAINER_MODE.patch
deleted file mode 100644
index 28d57a1..0000000
--- a/debian/patches/0002-get_rid_of_AM_MAINTAINER_MODE.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -14,9 +14,6 @@ AC_PROG_CC
- m4_pattern_allow([AM_PROG_AR]) # for automake 1.12
- AM_PROG_AR
-
--# Enable maintainer mode by default for development
--AM_MAINTAINER_MODE([enable])
--
- # Initialize libtool
- AC_PROG_LIBTOOL
- LT_INIT
diff --git a/debian/patches/0003-fix_manpage_section.patch b/debian/patches/0003-fix_manpage_section.patch
deleted file mode 100644
index 3ca2e55..0000000
--- a/debian/patches/0003-fix_manpage_section.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,9 +1,7 @@
- ACLOCAL_AMFLAGS = -I ../m4
- libexec_PROGRAMS = knot-zcompile unittests unittests-zcompile unittests-libknot-realdata unittests-libknot unittests-xfr
- sbin_PROGRAMS = knotc knotd
--MANPAGES = knotc.8 knotd.8 knot.conf.5
--man8_MANS = knotc.8 knotd.8 knot.conf.5
--EXTRA_DIST = $(man8_MANS)
-+dist_man_MANS = knot.conf.5 knotc.8 knotd.8
-
- # $(YACC) will generate header file
- AM_CFLAGS = -Wall -Ilibknot -DLIBEXECDIR='"$(libexecdir)"' -DSYSCONFDIR='"$(sysconfdir)"' -DSBINDIR='"$(sbindir)"'
diff --git a/debian/patches/series b/debian/patches/series
index cb8124a..683a828 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,2 @@
0001-move_pidfile_to_var_run.patch
-0002-get_rid_of_AM_MAINTAINER_MODE.patch
-0003-fix_manpage_section.patch
0004-disable_SSE2_detection.patch