summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure59
1 files changed, 45 insertions, 14 deletions
diff --git a/configure b/configure
index 3630ebb..51e19f3 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for knot 1.3.0-rc3.
+# Generated by GNU Autoconf 2.69 for knot 1.3.0-rc4.
#
# Report bugs to <knot-dns@labs.nic.cz>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='knot'
PACKAGE_TARNAME='knot'
-PACKAGE_VERSION='1.3.0-rc3'
-PACKAGE_STRING='knot 1.3.0-rc3'
+PACKAGE_VERSION='1.3.0-rc4'
+PACKAGE_STRING='knot 1.3.0-rc4'
PACKAGE_BUGREPORT='knot-dns@labs.nic.cz'
PACKAGE_URL=''
@@ -643,6 +643,7 @@ libcrypto_LIBS
libcrypto_CFLAGS
liburcu_LIBS
liburcu_CFLAGS
+config_dir
storage_dir
run_dir
FSM_TYPE
@@ -685,6 +686,7 @@ LIBTOOL
ac_ct_AR
AR
SIMD_FLAGS
+RELEASE_DATE
EGREP
GREP
CPP
@@ -786,10 +788,12 @@ enable_fastparser
enable_debug
enable_debuglevel
enable_recvmmsg
+enable_integrity_check
enable_lto
enable_microseconds_log
with_rundir
with_storage
+with_configdir
with_urcu
with_openssl
'
@@ -1351,7 +1355,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures knot 1.3.0-rc3 to adapt to many kinds of systems.
+\`configure' configures knot 1.3.0-rc4 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1421,7 +1425,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of knot 1.3.0-rc3:";;
+ short | recursive ) echo "Configuration of knot 1.3.0-rc4:";;
esac
cat <<\_ACEOF
@@ -1447,6 +1451,8 @@ Optional Features:
enable recvmmsg() network API under Linux (kernel
support required) (set to 'no' if you have trouble
running server under valgrind) [default=yes]
+ --enable-integrity-check
+ enable integrity check in knotd via SIGUSR1
--enable-lto=yes|no enable link-time optimizations, enable if not broken
for some extra speed [default=no]
--enable-microseconds-log
@@ -1461,9 +1467,11 @@ Optional Packages:
--with-sysroot=DIR Search for dependent libraries within DIR
(or the compiler's sysroot if not specified).
--with-rundir=path Path to run-time variable data (pid, sockets...).
- [default=`eval echo ${localstatedir}`/run/knot]
+ [default=LOCALSTATEDIR/run/knot]
--with-storage=path Default storage directory (slave zones, persistent
- data). [default=$(sharedstatedir)/knot]
+ data). [default=LOCALSTATEDIR/lib/knot]
+ --with-configdir=path Default directory for configuration.
+ [default=SYSCONFDIR/knot]
--with-urcu=DIR where to find userspace-rcu library
--with-openssl=DIR where to find openssl library
@@ -1562,7 +1570,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-knot configure 1.3.0-rc3
+knot configure 1.3.0-rc4
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1985,7 +1993,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by knot $as_me 1.3.0-rc3, which was
+It was created by knot $as_me 1.3.0-rc4, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2808,7 +2816,7 @@ fi
# Define the identity of the package.
PACKAGE='knot'
- VERSION='1.3.0-rc3'
+ VERSION='1.3.0-rc4'
cat >>confdefs.h <<_ACEOF
@@ -4331,6 +4339,11 @@ $as_echo "$ac_cv_safe_to_define___extensions__" >&6; }
+# Automatically update release date based on configure.ac date
+release_date=`doc/mdate-sh configure.ac`
+RELEASE_DATE=$release_date
+
+
# Check SSE, SSE2 and SSE3 support
ac_ext=c
@@ -13097,6 +13110,15 @@ $as_echo "#define ENABLE_RECVMMSG 1" >>confdefs.h
fi
+# Enable integrity check
+# Check whether --enable-integrity-check was given.
+if test "${enable_integrity_check+set}" = set; then :
+ enableval=$enable_integrity_check;
+$as_echo "#define INTEGRITY_CHECK 1" >>confdefs.h
+
+fi
+
+
# Check for link time optimizations support and predictive commoning
# Check whether --enable-lto was given.
if test "${enable_lto+set}" = set; then :
@@ -13241,7 +13263,7 @@ fi
-storage_dir="${sharedstatedir}/knot"
+storage_dir="${localstatedir}/lib/knot"
# Check whether --with-storage was given.
if test "${with_storage+set}" = set; then :
@@ -13250,6 +13272,15 @@ fi
+config_dir="${sysconfdir}/knot"
+
+# Check whether --with-configdir was given.
+if test "${with_configdir+set}" = set; then :
+ withval=$with_configdir; config_dir=$withval
+fi
+
+
+
# Checks for libraries.
# FIXME: Replace `main' with a function in `-lm':
@@ -14348,7 +14379,7 @@ $as_echo "#define DSFMT_MEXP 521" >>confdefs.h
# Checks for library functions.
-for ac_func in clock_gettime gettimeofday epoll_wait fgetln getline kqueue madvise poll posix_memalign pselect pthread_setaffinity_np regcomp select sendmmsg setgroups
+for ac_func in clock_gettime gettimeofday fgetln getline madvise poll posix_memalign pselect pthread_setaffinity_np regcomp select sendmmsg setgroups
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
@@ -14998,7 +15029,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by knot $as_me 1.3.0-rc3, which was
+This file was extended by knot $as_me 1.3.0-rc4, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -15064,7 +15095,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-knot config.status 1.3.0-rc3
+knot config.status 1.3.0-rc4
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"