summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index dddfcb9..3a418b2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,10 +10,9 @@
#export DH_VERBOSE=1
%:
- dh $@
+ dh $@ --with autoreconf,systemd
override_dh_auto_configure:
- autoreconf -fi
dh_auto_configure -- \
--sysconfdir=/etc/knot \
--localstatedir=/var/lib \
@@ -32,8 +31,14 @@ override_dh_strip:
dh_strip --dbg-package=knot-dbg
override_dh_install:
+ # Install sample conf as /etc/knot/knot.conf
mv $(CURDIR)/debian/tmp/etc/knot/knot.sample.conf $(CURDIR)/debian/tmp/etc/knot/knot.conf
+ # Remove useless example zone from /etc/knot
rm $(CURDIR)/debian/tmp/etc/knot/example.com.zone
+ # Install custom script which creates RUNDIR and chowns it according to conffile settings
+ install -m 755 -d $(CURDIR)/debian/tmp/usr/lib/knot/
+ install -m 755 $(CURDIR)/debian/prepare-environment $(CURDIR)/debian/tmp/usr/lib/knot/
+
dh_install --fail-missing
override_dh_installchangelogs: