summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Hommey <mh@glandium.org>2004-07-31 07:47:38 +0000
committerMike Hommey <mh@glandium.org>2004-07-31 07:47:38 +0000
commit717a3e922aa06fa9419f1dae8f64bbf48f4e1ffa (patch)
tree6044e5ca77ef95f8a55e8982c7653e8d0c4cacaf
parenta393935d68f63d8f21d98e4dd78cc1c62c09cc5d (diff)
downloadlibxml2-717a3e922aa06fa9419f1dae8f64bbf48f4e1ffa.tar.gz
debian/rules: Backup files that are removed or modified by upstream build system and restore them so that calling the clean target actually gives the same tree as before a build.
debian/changelog: removed the NOT RELEASED YET message. This will be 2.6.11-3.
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules22
2 files changed, 21 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 3fc1e72..87cfacd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,12 @@
libxml2 (2.6.11-3) unstable; urgency=low
- * NOT RELEASED YET
* debian/control: add a space between gcc-3.2 and [hppa]. Closes: #262101.
* python/drv_libxml2.py: add encoding declaration. Closes: #259526.
+ * debian/rules: Backup files that are removed or modified by upstream build
+ system and restore them so that calling the clean target actually gives
+ the same tree as before a build.
- -- Mike Hommey <mh@glandium.org> Sat, 31 Jul 2004 15:22:38 +0900
+ -- Mike Hommey <mh@glandium.org> Sat, 31 Jul 2004 16:44:06 +0900
libxml2 (2.6.11-2) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 04dbc7f..e0229ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+WORKAROUND_BACKUP_FILES=python/libxml2-py.c include/libxml/xmlversion.h libxml2.spec python/setup.py doc/xmlcatalog.1
+
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -19,13 +21,19 @@ build: build-stamp
build-stamp:
dh_testdir
+ # Workaround backups because of non-idempotent upstream:
+ for file in $(WORKAROUND_BACKUP_FILES); do \
+ cp -f -a $${file} $${file}-tmp; \
+ done
+
+ # ./configure
$(FORCEGCC) CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --with-python=/usr/bin/python2.3
echo "all:" > example/Makefile
echo "install:" >> example/Makefile
echo "distclean:" >> example/Makefile
echo " rm -rf .deps" >> example/Makefile
- cp -f -a python/libxml2-py.c python/libxml2-py.c-tmp
+ # Build libxml2
$(MAKE)
touch build-stamp
@@ -39,6 +47,13 @@ clean:
-rm -f example/Makefile
rm COPYING && cp Copyright COPYING
+ # Restore workaround backups
+ -for file in $(WORKAROUND_BACKUP_FILES); do \
+ test -r $${file}-tmp && \
+ cat $${file}-tmp > $${file} && \
+ rm -f $${file}-tmp; \
+ done
+
-test -r /usr/share/misc/config.sub && \
cp -f /usr/share/misc/config.sub config.sub
-test -r /usr/share/misc/config.guess && \
@@ -58,12 +73,9 @@ install-stamp: build-stamp
install
mkdir -p debian/tmp/usr/share/doc/libxml2-doc/html
- install doc/*.html doc/*.gif debian/tmp/usr/share/doc/libxml2-doc/html/
+ install -m 644 doc/*.html doc/*.gif debian/tmp/usr/share/doc/libxml2-doc/html/
mv debian/tmp/usr/share/aclocal/libxml.m4 debian/tmp/usr/share/aclocal/libxml2.m4
- -test -r python/libxml2-py.c-tmp && \
- cat python/libxml2-py.c-tmp > python/libxml2-py.c && \
- rm -f python/libxml2-py.c-tmp
touch install-stamp